MB-Lab 1.7.3 Release for Blender 2.80

add-ons
blender2-80

#82

I am not sure how that bug happened in the first place but I just fixed it, somehow I changed something somewhere and the eyes look much better in EEVEE now.

Just pushed the commit to the repository so you will need to update your clone


#83

Never mind… I already self-answered this.


(sqkychair) #84

Great job.
I guess I gotta play with Eevee a bit more but it just looks radically different from Cycles, Even the lamps work differently.


(dcrosby) #85

So you’re saying I can just stick with version 1.7.0 I’d already downloaded or there’s an updated version with the same version number?

My 2 cents: Don’t add anything to the lab. Squash bugs and make it compatible with the stable release version of B 2.8 when that releases. Work on documentation and promos that disappeared when Manuel did. Maybe you could gin up some interest from community members with the skills to contribute rather than just request more features. Don’t fall pray to MB-Madness like Manuel did.


#86

Version 1.7.1 was very buggy, it is now ok to use.

The documentation is lacking on our end for sure so I’ve been looking for solutions, which I found one that the Natron project uses. Readthedocs.org seems to be pretty good so I am going with that. Now to just get busy writing.

I also have been working on a site, hosted on GitHub of course, I don’t have a domain name yet so the URL is a bit long at this time and it is still a WIP but for the most part it’s done.

https://mb-lab-community.github.io/MB-Lab.github.io/

I think the next step is a promo video


(ma kadir) #87

thanks. where to find cloth assets ?


#88

You can find them here -



(Gilles Charbonneau) #89

Ok, I posted this in the proper thread, but I thought I might get a better response here, so I apologize for my double posting here!

I am trying to set a Rigify rig for MB-Lab in 2.8 using daniel Engler meta-rig add-on, but I get funky results, here is a recording of my process, anyone can tell me what i am doing wrong here?

Thanks in advance.


(sqkychair) #90

Yep, I am getting the same thing.
I want to pose a question here. Is it worth fixing the MBLAB rig or commit to getting the Rigify rig to work?
Although I’m no expert, I believe the MBLAB rig has issues with the IK. (Fingers don’t spread, head position, hips can’t tilt(try a female walk cycle))
I think Rigify is a much more mature rig but I like the convenience of the automatic MB rig.


(Gilles Charbonneau) #91

I just might end up using MB-Lab rig, I only need basic animation for GP, but it would be nice for users to have a working Rigify rig for it, as it is much more advanced!

In my case a better FK rig would be perfect!


(DanielEngler) #92

Did the rig or vertex groups change in MB-Lab? If so, my add-on is out of date and I’ll fix it over the weekend. If it’s a bug, same.

At 1:36 you choose “With Empty Groups”. That might mess things up. I’m not sure. I did not test this.
You should just choose “Armature Deform”, because the vertex groups are already there. Or even simpler: Just choose the rig object in the armature modifier.


(Bohdan Lvov) #93

That’s bloody awesome! Thanks for keeping such fantastic project alive!


(Gilles Charbonneau) #94

Will do, thanks!

EDIT : Same results…

Same with anime characters as well !


(Gilles Charbonneau) #95

Also, I would like to suggest that you turn on Super Finger by default in the metarig so we get the scale widget that allows fingers rotation, like it used to in old Rigify!


#97

I’m at work right now I’ll have to see what’s wrong on my end in a few hours when I get home.


#98

EDIT

So I checked to see if I made some mistake, I have not changed the rig nor the vertex groups. I am not sure what is causing this.


(Gilles Charbonneau) #99

Maybe then the problem lies in the Meta-Rig add-on, let’s see what Daniel come up with next weekend !


(Gilles Charbonneau) #100

Same happens with clothing, so my guess is that it has to do with the vertex groups somehow, on the plus side, the proxy system transfers to the Rigify rig no problems, which is very cool !


(DanielEngler) #101

This should be fixed, now.


(Gilles Charbonneau) #102

Cool, thanks a lot, will try it out a bit later and I will post the results, thanks again mate! :slight_smile: