[MBP + 2.71] Alt + Middle Mouse zoom shortcut doesn't work anymore

Hi folks!

I am new here, as well as new to Blender. (I’m a musician / I picked up Blender as a hobby) I recently downloaded Blender 2.71 and just when opened an old project file to continue my work, I noticed that the Alt + middle mouse shortcut didn’t work anymore. (the version I had before was 2.68) So, I go to Input > 3D View > Zoom View and manually create a “Alt + Middle Mouse” shortcut and after I press Save User Settings and go back to my project file, the shortcut doesn’t do anything. Is that a known issue? I searched the forums and Google first, to see whether anybody else has experienced this problem, but there’s nothing!

Thank you ~

By default
Shift+MMB = move view
Ctrl+MMB = zoom view

If you want to change zoom to shift+MMB you’ll have to disable the rotate view shortcut so there is no conflict

Oh, so is not possible to use Alt + MMB anymore? It was a really useful shortcut. I’d also like to keep Shift+MMB for move view and Ctrl+MMB for OSX’s zoom view.

With default settings, changing the zoom from Ctrl+MMB to Alt+MMB works just fine

That is very strange, I did exactly the same and it doesn’t work for me. (it used to, for 2.68) Would you have any idea why?

If you had changed it previously did you not select to copy your previous blender settings when you first started 2.71 ?
Have you changed anything else ? Check for other shortcut conflicts, go back to factory settings and try. If that works you changed something and you’ll need to find what you changed

Unfortunately I didn’t, as I used to use the default 2.68 key config + some addons, so it wasn’t a big deal to save it. Also, I checked to see if there are any conflicts for Alt+MMD and there is not! I have exactly what you have in your screenshot and it doesn’t work. I tried Factory Settings and it reverts back to Ctrl+MMD. I manually changed it back to Alt+MMD and it still doesn’t work.

So sorry for the arbitrary nature of this problem, I have no idea what the problem is!

Richard is the expert on the UI but there may be a hardcoded ALT MMB that creates snaps for the rotate view navigation. To reassign Alt MMB you might need to disable the MMB rotate view entirely.

I understand how overlapping works. It might be a bit of a primitive way of searching, but I went through all Input options, category by category and it was available. Is there a way to search within Blender? When I use that key shortcut in 3D View, it doesn’t do anything. Do you know whether Alt+MMD was replaced by something else in Blender 2.7x?

Sorry I edited my post to remove a lot of jabber that had already been covered above.

MMD alt is different from Alt MMD in that if you start the drag before pressing Alt it snaps to angle increments.

On my system I can easily change it to alt MMD zooming but I completely blanked on noticing that you said you are on Mac OS. I shouldn’t even have said anything in a MacOS question since I only know Linux and Windows but I believe the Alt key is weird in Mac mappings.

Oh it’s no problem, don’t worry about it! I think I might have to go back to 2.68, because I really need Alt+MMD working as zoom view and Ctrl+MMD as OSX’s native zoom function, it’s really unpractical for me otherwise. Thank you so much for your responses everyone, if anyone finds a solution to this problem in the meantime, please let me know, I’d very much like to understand whether I am doing anything wrong or is this a bug of sorts.

OK, I think I solved it: I redownloaded 2.68 and the option should be as “Alt+Mouse/Trackpad Pan” and “Any”. Thanks for all your help, people, really appreciate your responses.