Measure Tool - Works fine... but how to keep it visible? (2.8)

So the measure tool in 2.8 seems to be working just fine. I only mention this because I’d been told that blender wasn’t good for accuracy because the measure tools ‘just aren’t there yet’, but it seems to do the job (for me anyway).

I particularly like that you can snap the measure points to faces (and edges?). This is great. But I’ll come back to this.

Except… it’s only visible when you’re -using- the measure tool. So you measure a distance that you want an object to be, then you click on the ‘move’ tool to move the object… and the measure line vanishes. So you have to keep clicking back and forth between Move and Measure.

This seems… wrong. Like completely pointless?

What I would -like- to happen, is to snap the measure tool to two edges (this part works), then select and object and the move tool, and move one object -with the measuring tool still showing the ruler-.

Bonus points if the measuring tool stays snapped to the objects AS YOU MOVE THEM, so the distance is updated in real time.

This seems… relatively simple? If this doesn’t exist, I’m surprised that noone has done it in all the years of blenders existence.

Any thoughts? What am I doing wrong? Or is there a 3rd party tool I should be using instead?

1 Like

You can use the mesureit addon

Enable addon;
Edit > Preferences > Add-ons > 3D View : MeasureIt

Location: View 3D > Sidebar > View Tab

Took me a little trial and error figuring it out, but it seems to do the job :slight_smile: thanks!

This has bugged me as well when I have used the tool to get exact measurements. The workaround I found was to shift-right-click (to place the 3d cursor) approximately at the one end of the ruler to where I wanted to move something (or left click depending on your settings).

Another thing that is a little curious about the tool is that you can create an infinite amount of rulers, but you can’t as I understand it permanently delete them. You can only temporarily hide them by selecting them and clicking delete or ‘x’, and they show up again the next time you switch to measure mode. I can see how this might cause frustration in the long run.

To delete ruler: remove layer ‘RulerData3D’ within N panel (Property panel) -> View -> Annotations