MeasureIt_Arch is an attempt (aimed for architects and more) to expand and add features to MeasurIt , the built-in application existing for years, through several releases, including the latest 3.0

MeasureIt_Arch versions 0.4.0 and the latest 0.4.6 seem not to work with the latest version : Blender 3.0, under Windows 10.
The addon installs from the zip but trying to activate it returns an error.

Traceback (most recent call last):
File “C:\Program Files\Blender Foundation\Blender 3.0\3.0\scripts\modules\”, line 351, in enable
mod = import(module_name)
ModuleNotFoundError: No module named ‘MeasureIt_ARCH-mARCHv0’

Can anyone please confirm it’s not some problem of mine but general for these versions?
If someone related to the addon reads this, would you please inform of your intention to pursuit or not the adaption and continued development?
Note: I have reported this also on the Github / issues of this project, a few days ago, no reply yet.
(btw I can still run 0.4.0 under Blender 2.91, which was my previous setup)

Hi, I have it running on Win10 and Blender 3.0.1 (v4.7)

I like this fork mainly because it solves the problem with the measure text size that is not consistent between the 3D viewport and the render. Also it brings a useful style preset that can be applied to items. Hope one day Antonioa will look at this fork and give him inspirations to update his addon :grinning:.
One thing I don’t like in this fork is the panels are scattered everywhere I tried to contact the author about that some times ago but no reply…

@StroBlend thanks, maybe just the issue of the version or I don’t understand github and don’t download all the proper files.
In the installation directions I’m told to download the zip, there is actually one version 0.4.6 as the latest and another earlier v.0.4.0.
I tried both installing that from Preferences (I’ve done that for many addons, many times, I don’t think we need to go into detail, not about this)
Your addon screen clip shows you have 0.4.7 installed.
I go back to github and check the development branch. There the version is 0.5.0. I assume if 0.4.7 works so will this.
But there is no zip download of this (or I can’t find it…). How do I install? Just copy files over??


It took me a bit of time to find it again :sweat_smile:!
Click on the link that say: “Download the latest zip file from the releases page
Then scroll and scroll the page until you find the zip 0_4_7 (one quarter of the page)

I was not able to find a 0.5 version ?

1 Like

… Seriously??? … this is on the same page that is titled “MeasureIt-ARCH Version 0.4.6, latest, The Final Version 0.4 Series Release” that’s more than obscure! :grinning:
The 0.5.0 is easier to find… I think … see the edit in my post above for a screenshot.
I can confirm 0.5.0 installs and activates on Blender 3.0 :+1:

Apparently, according to description this is not backward compatible - It’s new to me, so that won’t matter.
But I am curious if 0.4.7 was backward compatible with the data of MeasurIt (the built in version)… I would think not, but can you confirm?

I have no idea for the backward compatibility but it worth the try, he talks about the developement branch so I understand (higher than 0_4_7)

overall do you find it useful? do you use it? is it reliable?
MeasurIt has been around for ages and is being updated enough to be included, built in, with new versions. I wonder which to use … the new MI_Arch has more features, for sure!

Yep I find it useful it fixes some issues I was facing with the builtin one but I didn’t tried the mesh edge render feature since I only use it for measurement

I love measureit arch and yes it works on my windows 10 with blender 3.0.1 and 3.1 beta

1 Like

Please post your addon version, thank you.
If it’s the newer 0.5.0 , did you loose backward compatibility with your old files?

I am using measureit arch 0.4.7 in blender 3.1 beta. No problems for me. The newest builds have an issue with archipack where I cannot generate dimensions on wall. So I regressed to 0.4.7 version and all is good