Mechanical Gears Error

I downloaded the mechanical gears script from, but when I try and run it I get this error message:

“Python script error: check console”

I’m using Blender 2.48a, Python 2.5.2 and Windows Vista. this is my first script to ever try and I’m at a loss.

Where did you put the script?

I got the same error on another script (mesh_wire). in my case, the mesh_wire script used another script (mesh_solidify) and tried to load it as a module, which is stored in another directory. I don’t have a windows box to try it in windows right away, but will try to look for one to try to duplicate your error…

I posted my findings here

In my scripts folder.

hi, this script is very old.
I do have a working version but,
there is a better script for gears in the add mesh section in the wiki.
(check my sig for link.)

Thanks for that script, but its still giving me the same error message. Maybe its my Python and I should reinstall it?

Are you trying Python Blender simple script or Game engine script? If first, it can work by pressing Ctrl+P in text window. But if you want play some game,you must press the “P” key on 3d view window or selest Game->Play in main menu. For viewing error messages you must open blender.exe from console(win+R cmd.exe)

Here are the links for the working, new gears script.

Those are the ones I used. I think it might be python, because none of my scripts are working. I’ll reinstall that when I get home and maybe Blender too.

It’s fairly easy to check whether Blender is able to find a full Python installation: when you start up blender, the console window should read:

Compiled with Python version 2.5.2.
Checking for installed Python… got it!

(you may have a slightly different Python version of course, but anything newer than 2.5 is generally ok).

If Blender can’t find Python, you may not have installed it properly: you may find this page usefull:

I’m also interested in what you actually see on the console (you mentioned a script error that referred you to the console but did not quote the actual error visible in the console).

I do get that Python message, so I do have full Python installed.

When I try to run a script this is the error message I get:

File "<string>?, line 1
execfile<r’C:\Users\Computer\AppData\Roaming\Blender Foundation\Blender.blender\scripts\’>

SyntaxError: invalid syntax

@slip: I have to admit I am a bit at a loss here… : I cannot reproduce the error (scripts are tested on 2.47 and now I tested it on 2.48 as well, but I haven’t yet installed the official 2.48a version ). Is it possible the script is unpacked improperly? To test if Blender doesn’t know where to find stuff or that there is something wrong with the script, you could try to run the script ‘by hand’, i.e. load it in the texteditor [texteditorwindow]->File->Open, then Alt-P (which runs the script from the textbuffer)

edit: cannot reproduce it on 2.48a (it’s all windows xp 32 bit here)

to see if the script downloaded correctly, you can compare its md5sum: on a complete python installation you can do this:

C:\Python25\Tools\Scripts>python “c:\Temp\”
7108668daf24ff50affedd5636b334f9 c:\Temp\

(of course your python installation directory might be different, as the location of the downloaded script, but you get the idea, that long hexadecimal string has to be the same as posted here)

I see that since version 2.48a there are some changes/bugfixes relating to python, especially the 64bit versions, committed to SVN, so there might be some issue there although I can’t find any clear comment on that.

I compiled the latest SVN version of blender and then I do get an error. I can’t say i understand why it crops up now, but i fixed it anyway. The fixed version (0.99a) can be found on my site (see sig) and its md5sum is:

C:\Temp>python c:\Python25\Tools\Scripts\

I downloaded the 0.99a version, but I’m still getting the same error message. Do you think it has anything to do with me running on Windows Vista?

I downloaded Blender 2.47 and it works fine now :slight_smile:

I think I’ll keep this for now. Thank you guys for all of your help!

Still I wonder what is wrong with 2.48a not working.