Media subdomain refuses connection preventing access to site

Something weird is going on with assets served through the media subdomain of BA. The connection keeps getting refused, resulting in the following:

The console is spitting several error messages seemingly related to the issue. Example:

workbox-strategies.prod.js:1 Uncaught (in promise) no-response: no-response :: [{"url":"https://media.blenderartists.org/uploads/default/optimized/4X/2/b/3/2b36d78088785b65e407955a93f543070834a8ee_2_477x1024.png"}]
    at a.makeRequest (https://media.blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
n @ workbox-core.prod.js:1
makeRequest @ workbox-strategies.prod.js:1
Failed to load resource: net::ERR_CONNECTION_REFUSED
https://media.blenderartists.org/stylesheets/discourse-details_3_8c67393a91c742bbbdcf852db33ccba6c92ff3de.css?__ws=blenderartists.org

Some avatars still load for now for being cached. I can’t access the site at all with a clear cache because no scripts load.

I checked our CDN traffic and there’s no dropoff at all, suggesting this might be a local issue for you. Could you check with another browser or another internet connection?

1 Like

Thanks for looking! It’s happening in all browsers I tried (Vivaldi, Chrome, Firefox Mobile). I can’t interrupt my connection atm but I’ll try to reset it later today.

How about on your phone?

It’s happening on Chrome, Vivaldi (both mobile and desktop) and Firefox Mobile. I had the chance to try it on a different ISP and also reset my connection to refresh the IP. Same issue; I can only post here for now thanks to the cached scripts.

Using a US VPN works.

It may be something temporarily off with the connection between our regions, or it could be a blanket IP range ban by the CDN. I’m outside the US and EU.