Megaman.....black face!?!?..er...need help..


(Riskbreaker) #1

Hey guys, wondering if anyone can help with this.
This megaman model is for joecool’s game, i’ll post it up later after i fix this problem. I applied a texture on it but most of the head just appears black when i put it in the textures visual mode (alt-z i think). I’ve already tried “recalc normals outside”

Heres what i mean…
http://users.tpg.com.au/tetsuo/screencapface.jpg

Dont mind the textures…i did that with a mouse and drew it from my memory.

Any help?


(banana_sock) #2

does it have the same problem when you render it?


(Riskbreaker) #3

No, not when i render. For that (render) , its alright. But when i use the realtime mode (game mode) thats what i get.


(kattkieru) #4

Try recalcing the normals. Edit mode -> select all verts -> Control + NKey. Usually stuff shows up black if the normals are screwy


(bmax) #5

if you would have paid attention, you would have known that he already did that. :-?

btw: have you tried setting all faces to 2-side faces?


(bob_dog) #6

There is a quick keyboard short cut answer to this, but I don’t remember what it is. Something about “inverting” the mesh or something like that. I wish I could remember where I saw that…

Warren


(Riskbreaker) #7

have you tried setting all faces to 2-side faces?

You mean did i turn “Double-Sided” on in Edit buttons? Yeah its on.

Still got a blank black face.


(viktorivar) #8

Try this, select model, press F, select black faces, F9,
press TexFace: Delete.

viktorivar


(Riskbreaker) #9

Cant do that. That gets rid of the entire mesh UV co-ordinates.


(viktorivar) #10

RISKBREAKER, I have got this black faces too : (

In my case it happens when I join different objects, and one of them
has UV co-ordinates, and guess witch one remains black : )

Yes, the one whitout/or with defect? UV co-ordinates.

In my humble opinion, the quickest way to fix it, is to remove them
from just the black faces and put on a new,
the unselected parts of mesh should remain as it was before.

If a better method is at hand please tell, that would be nice : )

viktorivar


(kos) #11

why don’t you delete all the faces that appear black and make fresh faces
with the vertices.apply UV-map to them.this might solve the problem.
BTW to make a face out of three or four verices select the vertices and press ‘F’.


(viktorivar) #12

You are right RISKBREAKER, all UV co-ordinates just disappeard on
my model too : ( …however, I tried a new way.

This time I separated the black faces from model
(select black face, push Tab, and then P button),
and then I put UV co-ordinates on black faces.

After that I joined faces back to model (select objects and use Ctrl+J)
and removed verticedoubles (select all vertices, F9,
use button Rem Doubles), that seems to work.

viktorivar


(Riskbreaker) #13

Thanx fellas for the help. I got it fixed now. If you guys wanna see it, i posted it in the realtime forum under the topic WANTED!

Thanx again (to all) for the great help :smiley: