Megascan does not see blender

Megascan does not see the blender in the export settings. How do I fix this error?
ms

Are you sure the plugin is installed?
Oh… And I assume this is Quixel Bridge, right?

And you have to install the addon for Blender as well, or it will not link both of the apps…

Yes, of course, the addon is installed. But strangely enough in the bridge itself there is no option to select the Blender preset.

Check the Edit > Manage Plugins tab in the top bar…MAKE sure that the Blender Plugin is downloaded and that the MS script folder is in the Blender Startup Folder …

Let us know…

Just to add, also for other people who might have issues…

The Megascans Blender plugin, after download in Bridge, can be found in the Megascan Library path, for me it’s D:\Quixel\MegaScans\support\plugins\blender. Latest addon version is 3.6

Just copy the MSPlugin folder over to your Blender scripts/addons folder, and activate it like any other addon.

Regarding the Bridge export dropdown.
On both of my machines, I see all export options, even though I don’t have them all installed. You don’t see any options, so I would suggest re-installing Bridge to see if that helps.
Be sure to delete all temp files under AppData\Roaming\Bridge as well to start fully fresh.

Hope it helps,

rob

The bridge is broken since Blender 3. There forum is full of complains https://help.quixel.com/hc/en-us/community/topics/360000088878-Blender

There is an unofficial version fix from a user.

But they still don‘t fix the official version, because it‘s free they think they let the Blender Bridge broken.

@stger Sorry, should have mentioned it works for 2.93LTS.

I’m not using 3.x as I consider these builds beta. With all the constant changes in the 3.x branch, I’m not using this for production, as it also breaks a lot of our own addons.

You can always fire up 2.93, import the assets from Bridge, and move on to 3.x :wink: