Merge scenes - solved. Thanks torukansama ^^

Hey all, :stuck_out_tongue:

Is it possible to merge some scenes into each other?
When I select overlay, some object that are supposed to go behind an object keep in front of it. (of course)

I wan’t to clean my file up a bit with adding more scenes so is it possible?

Hope you understand me.

Thanks :wink:

Hmm dont really know that. but just a tip. When you work use another layer instead of scenes. give you much more control of what you will see and not.

You need to understand that every scene is a world on it’s own. Instead of trying to do a magic trick, find a way around it. Add the elements of one scene into the other, via link!
BTW, what are you trying to accomplish?

Thanks though man. ^^

Well,

I’m making this game where I have a spaceship flying around a planet.
I wanted to make different planets with different enemies in another scene so that it’s a little less messy.
But the problem is that the bullets are supposed to disappear behind the planet.

First you got to elaborate more about the game structure. How do your scenes? Do you use background? How?
I’m also making a space game, and the player has to land on planets. On the background I’ve got a solar system scene, and each planet is another scene.
The game controls run on the main scene; the star systems run on the background; I added locations for the planets in the background, so if the camera approaches the planet, the planet scene is loaded. All playable elements have to be in the same scene for them to interact.

Here’s is a vid: (I improved the graphics a lot now)

I wanted to make every planet a background scene. The enemies could be added in the scene where the planet is. But the only problem goes to the bullets.

As you can see they turn around the planet. Which means they have to be in the same scene as the planet. The problem is that I have another scene (shop) which upgrades the weapons. And this way I would have to make that the weapons are upgraded in ever scene.

You have to think about balance. In a game, playability is far more important than options. If you need to add a shop, do it by using an overlay scene. You can also make the whole game run in the background.
If you really insist in having the planet on the background, the baddies must be in the same scene as the bullets. Which means you’ll need an empty firing the bullets in the same scene. If you need the baddies to be in a different scene of the planet, you’ll need to use an occluder to hide them as if they’re going behind the planet, which means an occluder sphere replacing the planet in the other scene, set to invisible.

The occluder is what I really need, but when I try it as you subscribed, the bullets won’t turn “invisible” because they are behind the occluder.

The enemies, the bullets and the occluder need to be in the same scene, and the planet on the background.
The occluder must occupy the area that is supposed to be behind the planet, it mustn’t rotate with the planet. Give it a transparent material instead of making it invisible.

How do I make a transparent material?
I tried a lot of ways but the bullets still wont disappear

Well, the bullets will disappear as they penetrate the occluder object. To make a transparent object, in the materials tab look for ztransparency, click the button, and look for the alpha slider, under the color slides, take it all the way to the left. To test if the bullets disappear, press the WIRE button to see the outines of the occluder object only.
Make sure the bullets and the occluder are in the same scene…
If you still have troubles I’ll send you a small example.

That was the first thing I tried, but do they have to move into the sphere or just behind it? Cause it ain’t working sry.

Hey,

Today I tried again… and for some reason it suddenly does work. So thanks a lot! ^^

You’re very welcome! I’m glad I could help!