Mesh and weight painting overlapping each other

Hello. I’ve joined the forum to see if anyone can help me. For some reason when I use the paint weight tool it looks like this. I’ve tried uninstalling Blender, deleting appdata, everything. I don’t know what’s going on. In Cycles it doesn’t look like that, but I’m not going to be working weights in cycles that would be crazy. The last image is the same file but on another computer and no problem is seen.

Any idea what the hell it could be?

Hello and welcome to blenderartists !

If the same file doesn’t give the same results, it’s either that they are not running the same blender version, or that could be something related to your graphic card.

Does weight paint work if you try it on the default scene (cube) ?

If it’s related to the graphic card, what’s the model ? you may try to fill a bug report. If that card is officially supported by blender then it will be fixed.

Good luck !


What do your Stroke menu settings look like? I’m not sure what that it is Spanish but it looks like you may need to turn the spacing down


If i add some subdivisions:
In the default cube is blue but the overlay is present

  • GPU
    AMD Radeon RX 6600 XT
  • CPU
    AMD Ryzen 5 5600X 6-Core Processor
    6 Cores
  • Ram

In the same way as you i’m not sure that is Stroke menu. Can you show me a pic or something?

EDIT: i found this:

So I think it’s going to be an incompatibility problem with version 3.0.0 and 3.1.2, which are the two I’ve used. I’m going to try old versions to see if I can get it to display correctly.

Greetings !

1 Like

Is it possible you duplicated your mesh while in edit mode and didn’t realize it?

1 Like

I think it is not possible. I have created a cube from scratch and added a couple of subdivisions and it still looks the same as you can see in the image above