Mesh breaking apart when using motion actuator.

Earlier this year, I posted about issues I was having with a space ship game. I had finished the game, and now I’m trying to put it on a mac so my friends that use macs can play it. Unfortunately, when I try to use the motion actuators, the ship wobbles around and then breaks apart. This is on an Intel-based iMac running OS X 10.7. It worked fine on the Windows 7 computer.

Here’s a screenshot of the game:


I’ve now found out that it only breaks apart when using the Loc or Rot in the simple motion. Did something change in the simple motion in 2.63?

loc and rot is like “teleporting” rot might be fine on small turns and small to medium size objects. Loc definitively conflicts with the Physics system.

As far as I know there is a bug in 2.63 regarding the parameters of the motion actuator.

I was using rot as a turning system for the ship. It worked on earlier versions of blender, so I guess I’ll do it on an earlier one or wait to see if the next release will fix the problem. Thanks.