Mesh Colour and Texture


(stefan 88) #1

First off I am pretty new at blender. Now to my question… I designed a building. Then to make texturing easier I selected the parts of the building I want to have the same texture and joined them (ctrl+j). Then I applied the texture. My problem is that the texture does not appear on all the objects joined. It only appears on some. The same happens with colour. When I try to change the colour, only certain objects are affected, the same ones that show the texture image. Exactly what happened? And most importantly, how to I apply the texture to everything? By the way most of the objects I created I made by extruding vertices, not reshaping squares.

P.S. HELP ME!!! This project is due very soon for school.


(Spin) #2

Post a BLEND file, we’ll take a look at it.
It seems like its a mess. Few simple steps can clean it up.

Takes longer to explain it than to actually do it.


(stefan 88) #3

How do I post a blend file lol? If you want I could e-mail you it. My email is [email protected]


(SoylentGreen) #4

The Objects keep their materials, even if you join them. So joining was probably a bad idea in the first place.

This is what you need:
http://mediawiki.blender.org/index.php/Manual/PartIII/Multiple_Materials


(stefan 88) #5

So I need to start over?


(SoylentGreen) #6

You have an older version of the file before you joined the meshes?

If you dont’t you have two possibilities:

  1. Separate the meshes
    ->Select the vertices you want to separate, p Key, new Object. Assign a new Material to your object.

  2. Use multiple materials (the link I’ve posted).


(shr1k) #7

blender has an auto save function do a search on your computer for .blend if you dont know where blender is saving them. they will be named with a number start opening up the blends and checking to se if you have one before every thing was joined.