Mesh Deform Modifer: Does nothing!

I read this:
http://wiki.blender.org/index.php/Doc:Manual/Modifiers/Deform/MeshDeform

And I followed this:

I have a cube, with generic OB and ME names
I have a cage, OB:Cage ME:Cage

When ever I modify the OB:Cage mesh, in Edit mode, nothing happens to the inner cube at all.

What I have done:
clicked the inner cube, in object mode
added a Mesh Deform modifier
told the Mesh Deform Modifier I want to use OB:Cage as the mesh, but I typed “Cage” obviously, and not “OB:Cage”
I then hit Bind

I then try to modify the OB:Cage, and nothing happens at all. Wow, what a great feature.

More info: When I click apply, the modifier either disappears from the list of modifiers, or says it’s not enabled, or there may have been an error.

FYI, I have python 2.6.2 installed and blender detects it.

What’s going on?

Hi,

I’ve just tried that and it worked fine for me.

You don’t need to click Apply unless you want to freeze the deformation to the Cube object and remove the modifier.

The steps you listed should be enough to get the mesh deform modifier working.

… Doesn’t work. Can someone write out the steps exactly.

Hi,

  • Create a cube. Make sure it’s object name is Cube.
  • Create a cube and scale it up a little. Change it’s object name to Cage.
  • Right-click Cube.
  • Add a MeshDeform modifier in the Editing buttons (F9).
  • Type Cage into the Ob: textbox.
  • Click Bind.
  • Wait until the binding has finished (see progress bar at top of screen).
  • Right-click Cage.
  • Press Tab.
  • Right-click a vertex.
  • Press G.
  • Move the mouse.

Hmmm, I seem to have solved it.

So when I was making the cage before, I was assuming that it didn’t need faces. So I built a cage with just edges, no faces (so it wouldn’t render)

Apparently it only works, if your cage has faces. Good to know!

Thanks for the quick replies & step by step play.

-DaVinG