Mesh Edit Tool not showing - Bug or just bad UI

Hello, recently I set my viewport to the right side of my screen due to use of multiple monitors and having the main stuff in the middle. Then I’ve noticed something rather annoying. Apperently when I create new mesh shape, I don’t get the “mesh” edit window anymore, I only get it when the viewport is on the left side of the screen. Is this some sort of bug, or bad UI? Can it be set in the settings?
BlenderAddMeshMenu

On the right viewport, try going up to View->Adjust Last Operator and turning it off, and then turning it back on. That seems to switch which viewport it shows up on in my testing.

That popup panel is so clumsy, I can’t tell what is deliberate or a bug in terms of how it behaves.

1 Like

Thanks, yeah, that helped.