Mesh has strange black shadows

Hi, I am creating a damage worn bridge using Blender, I hope there is simple answer to my question.

http://i1326.photobucket.com/albums/u656/errorbot/HL2%20level%20bridge%20area/june%20bridge%202014/bsupports2pic30A_zpsdfc01a59.png

http://i1326.photobucket.com/albums/u656/errorbot/HL2%20level%20bridge%20area/june%20bridge%202014/bsupports2pic32A_zpsf827dcf6.png

I have noticed Black shadows on my mesh, I have recalculated normals and deleted double vertices, nothing seems to work. Is it possible to fix this? or is this just how normals work. It makes the texture I use have extra shadows, to be honest I would like to get rid of these black shadows if possible.

http://i1326.photobucket.com/albums/u656/errorbot/HL2%20level%20bridge%20area/june%20bridge%202014/bsupports2pic33A_zpsc846173f.png

http://i1326.photobucket.com/albums/u656/errorbot/HL2%20level%20bridge%20area/june%20bridge%202014/bsupports2pic34Anormals_zps40d86416.png

I can post the Blend file of the mesh if need be.

Thanks.

Assuming the mesh is clean (no interior faces for example), try marking edges as sharp and add edge split modifier.

Thanks JA12, the mesh had smooth shading all over. I selected the mesh and selected Flat shading. Black shadows have disappeared I find this strange some what.

http://i1326.photobucket.com/albums/u656/errorbot/HL2%20level%20bridge%20area/june%20bridge%202014/blenderquestionbridgesupportB_zpsd892f990.png

Added an edge split modifier at 30 degrees but I can’t see any changes to the flat shading. I looked up auto smooth in Blender, I can’t find auto smooth it should be in the object data area in the properties panel under normals I see nothing there. Edge split seems to have the same functions as auto smoothing but it is not exactly the same,

I noticed in edit mode I can select faces to be smooth and some to be flat, so that is what I have done the X part of the mesh is smooth and the rest is flat. The problem I can see here is while it is great to be able to do this. How can I tell quickly what faces are smooth and which are flat? Like perhaps a colour overlay option say green faces would tell you that face/s is flat and blue faces are smooth. I have also heard the term smoothing groups would you know where they are?

Unsure you have a consistent normal direction across your mesh.
Display the normals in the properties panel (N).
Flip selected faces with W / Flip Normals
Ensure you remove any internal faces or double vertices (W / remove doubles) before recalculating your selected normals (Ctrl+N)

That’s where you confused yourself. Edge split modifier is used to control the smooth shading by splitting edges. By marking edges sharp you have the most control over it. Autosmooth works the same way as edge split modifier with the angle option but only works in render.

https://dl.dropboxusercontent.com/u/26346140/smooth_shading_options.avi