Mesh is attaching to armature too close

Everytime I weight paint the leg to the bone it clings to close, how can I stop this? I have also tried envelopes.


can you post blend file? The mesh shouldn’t deform when you weight it to a bone, unless the rig is posed in pose mode.

the bone it is supposed to be attached to, probably has a different position/location/scale in editmode and pose mode. You can check it out by turning on “axes” in the armature tab. Go in and out of editmode, and if the axis are changed, either change the roll of the bone (ctrl+R) or, more likely, change the pole offset value on the IK constraint.
that’s just the roll, I doubt it will be the scale or location you’ll need to worry about.

Blender file


Salesman 4.blend (239 KB)

Change the “To:” value to the last “-” in the “Locked Track” constraint on the ‘Leg.Lower_L’ bone.

Thankyou very much :slight_smile:

Another problem. When i switch from edit mode to pose mode the bones and mesh move, but i want it to stay as i set it in edit mode.


Salesman 6.blend (331 KB)

You have the “Upper Arm L” bone copying the location of the 'Shoulder Socket" bone. They are not origionally in the same place in edit mode, so they will snap in pose mode because of the constraint.

Go into edit mode of the armature, select the base of the "Shoulder Socket L’ bone, press shift + s and snap the cursor to selection. Then select the base of the “Upper Arm L” bone, press shift + s again and snap selection to cursor. Then adjust the rest of the chain accordingly. Or you can do that in reverse and move the shoulder socket bone, be sure to move the “_IK_Upper Arm L” bone too if you do so.

doesnt work lol

I just click the “con” button on the upperarm…seems to work :slight_smile:

Hi could you link this mesh and armature together please, and if you could record how you did it. I would be SOOOO GRATEFUL :smiley:


Salesman need help.blend (737 KB)

I got told i had to use this armature to attach to this mesh, however the armature is to small for the mesh. So i went into object mode and scaled it, then went into edit mode to move certain bones to fit the mesh. Now it fits in edit mode, but when i go to pose mode it all changes. I have re done it loads of times, each time something else changes when i go into pose mode. Whats happening?


Salesman need help 2.blend (737 KB)

umm…I’m not really sure what your problem is…I just checked out the last file you have attached to your last post and I can go from pose to object to edit mode and nothing strange happens. In the file attached to the next to last post, the armature is smaller than the character, but I don’t see anything wrong there either. The only thing I noticed is that when you scaled up the armature and repositioned it, you didn’t scale the the text for the fk/ik sliders. The bones that are the sliders themselves did get scaled, but the text that tells the animator what the sliders are and thier range of movement didn’t get scaled.


How do i do “scale the the text for the fk/ik sliders.”

Also the “Salesman need help 2.blend (737.1 KB, 3 views)” file, does change. Go to front view then switch between pose and object, the legs shift up and down. This can also be seen in the side view.

ok, the fk/ik sliders are on the last armature layer in the first group. In the editing panel, under armatures, there is a display options panel that consists of two groups of 8 boxes. The fk/ik sliders are on the 8th box from the left. When those bones were scaled up, the text & box for the slider need to be scaled as well. I don’t know how you scaled those bones (where you scaling pivot point was), but I can select the text & box and scale and move it in object mode to get it close to where they should be.

As for the problem with the legs moving between object and pose modes… on the second group of 8 bone layers, the layer on the left contains leg bones that did not get scaled with the leg bones on the first layer. (the arms where scaled) Also, the toe bones (there are two of them) appear to be folded back onto the foot bones. I don’t know if that is a problem with the constraints on those bones or not. This rig has python scripts with some of the constraints, and I don’t understand or have worked with them, so I’m not much help there. I have never scaled an armature or reused one, I make them for the character and I’m not a pro at rigging.

I did play around with your file a bit, I scaled one of the fk/ik slider boxes and moved it around. I also turned on the bone layer with the leg bones that did not get scaled and the layer with the fk/ik slider bones. See the attached file.

Sorry I’m not more help, but I hope the things I noticed give you some direction.


Salesman need help 2-1.blend (731 KB)

Hey cheers!!! I’ve managed to sort out the the leg problem now, but I cant quite figure out how to sort out the feet.


Salesman 4.blend (738 KB)

hey ttrtomboy,

I see this is giving you some trouble… at this point it seems the feet are actually not working properly anymore, likely because they have been repositioned improperly at some point in the process. You can either fix them by figuring out how they were broken, or just start over with the original rig as I have done here. This takes only a few minutes (for this rig atleast… more controls = more time) when it is done properly.

The steps I used are as follows:

  • Open the file with the rig, save it as a new file, and clean out all the unwanted geometry from the old character.
  • Append the new character mesh to the file.
  • Scale the mesh (not the armature) to fit the general proportions of the armature. The reason for not scaling the armature is just to prevent problems when applying the transforms… some armatures will be fine, some won’t - so it’s best just to avoid scaling it altogether. When the mesh is scaled nicely in object mode, press ‘ctrl+a’ to apply the transforms to the mesh.
  • In edit mode of the armature, make all of the bone layers visible (this is the step I think you missed, since every example file in this thread has evidence of missing this lol :slight_smile: In this rig there are IK and FK leg and arm chains, and they both must be positioned together! Plus all the mechanisms… keep everything together.)
  • Now reposition the joints to fit, being mindful of how the mechanisms interact (again, some rigs are more complicated than others. Nathan’s Biped Rig is a nice simple rig for this process.) Also note that when repositioning joints, it is best to do whole chains together (like a whole arm) to prevent the bones from rolling as much as possible. Whole selections can be manipulated and scaled easily in edit mode. Save individual joint tweaking for the very end… do it as little as possible, and constrain to an axis everytime you do it!
  • Check to make sure only the bones you want to deform have ‘deform’ enabled in the edit panel, then parent the mesh to the armature and choose ‘bone heat weighting’ to give yourself a head start for weight painting.

**I also rotated the hands to be palm-down. In the future I suggest building all of your characters this way, since it is the natural resting position of the hands and so rigs are most often built with palms facing down. You will still need to add in extra fingers and facial controls and polish the weight painting, but otherwise… voilà! :slight_smile:

**Note that you can scale the armature in object mode to set the scale of your character before beginning animation, to fit the scale of your scene.


Salesman.blend (431 KB)