Mesh not displaying in the engine


I have had this problem for a while, the face on a character doesn’t display, as well it isn’t just that, the shoes also don’t display.

I tried flip normals, recalculate, as well face flip normals.

Nothing is happening with that.


Why have you not supplied a link to your .blend file ?
Is it a deliberate policy to make it as difficult as possible for anyone to be able to help you ?

Get rid of all the uneccessary crap from your .blend before supplying a link to it

I don’t supply links to files I’m editing.

I don’t see what could be causing the problem. My instinct tells me to just retexture the face, and or seperate it and try again.


Actually I’m not replying to this post but as a new comer into the forum, I just want to say hello to you old folks.


That makes it a lot harder to debug. Particularly if you have tried the obvious things.


  • Turn on visualize normals so you can actually see what way they actually face. I have come across places where I have to manually set normals as the automatic tool doesn’t understand the object well enough.
  • Ensure transparency for the objects is turned off
  • Make sure you haven’t set an object physics type to occluder

Visualise normals? I tried looking in the Blender book for Dummies, as well as the index, I can’t find anything on that.

There certainly isn’t any transparency.

As for physics type where would I toggled a setting for that to occur?

I tried seperating the Mesh. No change. I have left the character out of my demo for the moment. In another layer.

To visualize normals:

The little blue lines are very useful and show which way the face is, well, facing.

If there isn’t transparency, make sure it is disabled/greyed out in the material:

And the occluder settings are in the physics panel:
Also make sure the invisible button isn’t clicked. (bottom button in above screeshot)


None of that seems to be the problem, here is image with the faces on.


I still can’t see the face normal blue iines. It’s the lower red circle in the top image of my previous post.

I do not think this is a problem with normals. He would see the backside of the mesh. It seams the complete mesh is not visible, or is not present in front of the camera.

Without blend file … everything is a wild guess.

Why not unparent it from whatever you have and check if you can see it as single object?

Monster I did try that.

I thinking if I can’t solve this, I’ll try a new mesh for the figure, since when I first created that file, I had found a better reference image. Also the shoes don’t display either.