Mesh not moving 1 to 1 with rig...Please help

Hi, I’m working on a character model and I had everything done and rigged and nice, but then I decided I wanted to rig the ears so I could move them. So I added a few more bones to the rig for the ears and reparented the rig to the mesh. Now the whole thing is messed up. The mesh will not move 1 to 1 with the rig. Oddly enough, the movement is off on different areas too. Such as when I turn the head bone, the head of the mesh is behind, and when I rotate the hand bone, the hand part of the mesh is ahead. I feel like things went wrong because I reparented (with automatic weights) a rig to a mesh that it was already parented to just to add the ear bones. Just a guess. However, I can’t figure out how to removed the rig from the mesh before reparenting it with the new bones. I’ve included pictures of my problem, and I wish I could include the blend file, but the forum says it’s too large so I can’t. I have a deadline to complete this model and this is a major setback. I need to resolve this quickly. Any help would be very much appreciated. Please feel free to ask me any questions in effort to help resolve this. Thanks so much!

Attachments



Check your modifiers list. When you re-parented, another Armature modifier was created for that parenting, but the old one was not removed. So now you probably have two, both influencing the mesh. Delete one or the other. You can determine which is better to delete by disabling them one at a time and trying the enabled one to see which gives better motion, though I’m not sure there will be any difference, since they both should target the same rig.

BTW, you need not re-parent at all after editing either your rig or your skinned mesh – the Armature modifier can stay in effect, as can the parent/child relationship. You need only add and weight a new vertex group for each new bone added. When mesh editing, the same pretty much applies, depending on the type of edit.

Ah, that was exactly the problem. Thank you so so much chipmasque! Also, thanks for the advice on just adding a new vertex group. I can’t thank you enough. Now I can get back to work :slight_smile: