Mesh not Skinning problem.

Hello everyone! Hoping you can help me solve this frustrating trouble! I should mention this is NOT my first time rigging a model. I have been using blender for over a year now, I have a half decent understanding of weight painting and automatic binding and all that. And this makes no sense to me. The Mesh is just binding incorrectly it’s obvious. I just don’t understand WHY this is happening. Hopefully this pictures can do most the talking, and someone might know what my problem is. I’m BEGGING you guys for help; WHY is this hand mesh skinned so funky?! it’s driving me nuts!

And the 3rd picture is the OTHER hand, which is bound perfectly (For my intermediate level of skill that is :P)
Thanks in advance, I love this community!!!

Attachments




Can you post the blend?

Here it is. I only uploaded the mesh that I’m having trouble with, and the rig. Because I’m paranoid like that :stuck_out_tongue: It’s worth noting, I think, that I’m also having an odd bug Where I cant see the axis in edit mode when I turn axis on. So maybe something is wrong with my machine? On another note I’ve never Uploaded a .blend before, but I think this should do the trick. https://dl.dropbox.com/u/13183582/Upload.blend

Maybe you want to see the axes for the armature instead? You can find that option in Armature options.

I took a look at your blend and saw the problem. The right hand is being affected by the left side of the mesh, and the fingers are also affected by other fingers. To fix this, select a vertex of let’s say the right index finger at the tip. Then, box or marquee select the rest of the finger until the first knuckle. In the n-panel at the top you will see a list called Vertex Groups. That’s a list of all the vertex groups affecting the vertices you selected. You will see that a lot of other stuff is affecting your index finger.

To fix this, set all of the .L weights to 0, and the .R weights that have nothing to do with the index finger (thumb, pinky etc). Then press Copy to set the weights for every vertex you selected. This is a bit rough, but you can fine tune the weights around the knuckles later. Repeat this process for every bone in the hand (select the vertices that should be affected by a certain bone and set the correct weights) and you should be okay.

Ah! You were right about the Axis, That was a stupid mistake on my end. Thank you for taking the time to respond! I actually found another solution; before, I was copying the hand mesh, then scaling it on the center over the the other side. That was creating the funky hand skinning situation. So instead I duplicated and separated the hand mesh, MIRRORED it over, and then ctrl+j’d it back to the rest of the body. That fixed the weird skinning situation. I guess mesh shouldn’t be mirrored over like armatures!! Thanks again, There’s nothing quiet like a helpful community. :smiley: