Mesh Shoots off Like a Rocket!

I have figured out how to model, uv and link a simple mesh to an armature.
Then I figured out how to make actions and “call” to them in a game environment.
Now when I try to make my character a dynamic actor it flies off the screen.
What have I done wrong? Here is a .blend.

Thank you for your help.

Both your armature and your character are set to dynamic. The only thing that should be dynamic (to my understanding) is the armature.

Thanks for the response. I now have another question.

I set just the armature to actor/dynamic and turned up the radius setting, but for some reason the character falls 1/2 way through the floor before it comes to rest. How do I get the object to rest on its feet, not midsection?


Thats odd. I usually use a vertical cilinder as the dynamic object, and the parent of all the other charcter objects. That way, you have a more acurate, stable and easy to control rig. Try that.

The root bone is the first bone you created and likely about the size your character is falling to. I think the coliision radius is being create propotionally to this center bone which is an issue that needs to be resovled so you won’t need to parent your armature to another object set to invisible to handle proper collision. Which is what you are going to need to do for now. I think.

I put a cylinder in the room and made it dynamic without parenting it to anything. It to flies off to the heavenlies. This is aggrivating because all week I have been making different models. Once I get them to this stage they fly away. I chose to make this simple and terrible model to save time and focus on the physics of things.


jessegp, I posted before I saw you posted. I took a look at the armature after reading your post and have figured out what is going on. The center of the armature is where the object is stopping at. How can I re-locate the center of my armature. I know how to do it with meshes, but can’t seem to locate a button that will let me do it with armatures.

Also, what could I do in the future to avoid this problem? IE. what are the proper steps to rigging a model and making it usable in the game environment.


I’m not sure if you can change the center of an armature, but i don’t know for sure. If you go back to your cyclinder in object mode press (f7) click bounds for draw extra. This will help you see if you are setting your cylinder’s bounds inside of another object’s. Doing so will make the cylinder jump away. Next make sure that the cylinder center point is in the middle of the cylinder. I think i’ve come across some problems if its not. I hope some of this help with the cylinder acting correctly.

I’ve only rigged one model and am playing with it right now so i don’t know much but was watching my model fall to the middle area if i used the armature as the colliding object. And then changine the collision radius my character would fall a little less into the ground. That’s why i believed the radius adjustment is proportional to the objects size, this case the root bone since it doesn’t surround the entire armature.

Well, I know that you can change the centre of the armature by going into edit mode, and moving all the bones until you see a good spot for it. This way doesn’t work very well because while you’re moving the bones in edit mode, the mesh won’t follow, so you will need to reposition the mesh after you’ve changed the centre of the armature, otherwise your entire animation would look screwed up.

If anyone knows another way of moving the centre of the armature, please let me know, because I really don’t like this way. :frowning:

Does anyone know of a good link to a tutorial on how to setup a model and rig it, and then animate it? I have looked over OTO’s tutorials, but for some reason it is not working with this guy.


what part are you stuck on

Try selecting everything in object mode and doing alt-r, alt-g, alt-s.

Here you go!

Saxofoner : I’m not stuck anywhere on it, I am simply experiencing the Blender paradox. You know, that strange thing that happens when you do a tutorial and it does not work. Then you repeat the process fifty times and suddenly for some reason it works. I keep gleaning small parts of info and keep picking up a few more pieces until it all goes together. For now, I just can’t seem to figure out how to make my own model/rig without it going ape in the physics dpt.

unsettlingsilence: Thanks for the link, I am downloading right now.


OK these two things are related.

I have figured out how to model, uv and link a simple mesh to an armature.
Now when I try to make my character a dynamic actor it flies off the screen.

Select your character and enter face mode by pressing “F”. Pull up your “Editing” buttons by pressing F9. Now select all your faces and under the tab labled “Texture face” deselect the button labled “Collision”. Finally near the bottom click the button labled “Copy DrawMode”.

The reason this works is that your dynamic object is resolving collisions and is basically colliding with itself. Shutting off the Collision flag on your characters faces solves the problem of self collision.

Also dont forget to turn of “Actor” and “Dynamic” on your armature as suggested by QNev.



Awesome that worked honeycomb. Thanks.