Mesh to Curve Tolerance?

Another day, another Blender problem. :stuck_out_tongue:

I’m trying to take this mesh and turn it into a smooth 2-node bezier curve:

The problem that I’m facing is that when I select the edges, and use the ‘Convert to Curve from Mesh’ tool, the tool follows the edges too tightly, and creates two nodes at every point to simulate the straight edges of the mesh. Here’s a picture:

Is there a setting somewhere to tone down the tolerance on this tool, so that I get a smooth bezier with the only nodes at each end?

Thanks in advance,

there is the curve simplify addons that can reduce qty of points on curves!
or do it manually with resolution

happy blendering

Thanks for the quick reply!

I tried out the curve simplify addon, but no matter what I set the maximum error to, the number of points doesn’t change. The resolution setting doesn’t seem to affect it either.

showsome pic of what yo did and if possible upload file with curve

happy blendering

Here’s the .blend file.

curve.blend (437 KB)

Thanks for the help!

first problem i see is that all edge are disconnected

how did you this curve ?

you could add a simple curve remove points and keep only 2 points then adjust curve with handles!

happy blendering

I made it by using the mesh to curve option on geometry that isn’t included in the file I attached. I could make the bezier by hand and adjust the handles manually, but I plan to make more complex things in this manner in the future and would like a easy way of doing this.


it should not give disconnect edges like that

make certain that you select a line mesh then convert again and see that you get a continous curve
did it many times it should work fine!

let us know if it works

getting late for me might wait tomorrow to continue or later on this night !

happy blendering

Well there is no reason why you couldn’t have made the same shape with a curve from the beginning. There are 2 points that are away from the over all shape select one and then a point on the main shape and Alt-M to merge the points together. Do this for the remaining point left over. Then remove doubles by selecting everything and pressing W and then selecting remove doubles and 12 points should be eliminated. Back in object mode convert the mesh to curve. You should no longer have any problems.

The reason there were 2 control points at each point was that each segment was converted to a curve element. All you had to do was remove doubles before converting.

forgot something
this was a curve not a mesh but instead of having one continous curve it was l;ike 12 curves made of 12 segment disconnected

not certain how you can end up with something like that !
never had thos problem before!


Thanks for the remove doubles tip, I was looking for a comand like that. Now I have only 16 verts like I should, but I’m still stuck on converting that to a two node bezier curve. The simplify edges script isn’t working properly.

Thanks all!

is it a mesh line or a curve?
the file you uploaded was already as a curve not a mesh line


It is currently a mesh line, I’ll re-upload it for you.


mesh.blend (434 KB)