Mesh won't follow the Rig, parenting issue?

I have an animal mesh, already rigged. The Client gave the file to my boss, my boss gave it to me.
Issue: I start animating, moving bones, setting keys…nope. The mesh isn’t moving. Ok…Select the mesh, Shift+Select the rig, Control+P…parent. Try Auto Weights. nope, the mesh gets reeeeeally huge and takes on a different orientation…tail in the air. yikes! I tried a few others…but so far, nope…How do I Delete History in Blender, (Maya terms) . Can I reset the mesh ? should I reset the rig in a cleaned way…no rotation and scale to alter the two parts? what to do? Thank you sooooo much.
Maybe make new rig > fresh start?

Oh! You can reset the mesh for your more effort on your work.

Can you share your file? Hard to see what you have otherwise.

https://drive.google.com/drive/folders/1S7x35H5PMrsc1rdeOG6OzhpAU3_SuZQx
Here is a link to my google drive folder. where this file is. I put a place holder in for the background, as that strips some of the megs out. Otherwise, I can put screen shots here… Thank you so much.

This is what it looks like when I select the mesh, then Shift select the rig.

What it looks like when I select the chest bone and rotate. Well…I selected the rest of the chest bones so it is easier to see. The bones move but the mesh will not follow.

What it looks like when I select Mesh, Shift select Rig, Control + P…and chose Automatic Weights


You can see the crocodiles stomach enormous in the rendered view. And see the bones tiny in the wire frame view…

There is probably a check box I missed …It seems like I am blocked in assigning the bones to the mesh. This model came with several LoD…maybe it is set up to use the other LoD …i will try that. But I really would like to know how to solve this for future use.
With gratitude…Thank you very much for looking. Thank you very much for your suggestions too. Learning is my friend.
~ Kelle

I cleared parent and the model pops into the Humongous scale again…standing on it’s tail. Something is up with the settings of the parenting? I’ll seek more on this concept.

I hear that Control A will Apply Dimension changes a coworker did to this mesh and rig. There is no Vertex Groups showing in the Object Data Properties. No Shape Keys…empty…should have Vertex groups…I think?? I want to better understand this.
Please describe what you know about this. I am super grateful. thank you. ~ Kelle

Need to fix your permissions on your file. It can’t be downloaded without you allowing access.

Can’t download file. But what you’re describing sounds like issues with unapplied scale on the original parenting that are hidden in the parenting inverse.

First, if you have any keyframes on your armature (bones are fine, just not the armature object itself), delete those. Then clear loc/rot/scale on the armature object, alt g alt r alt s. (You might consider just duplicating the armature really quick, so you can copy/paste keyframes from the duplicate when you’re done.)

Now unparent your mesh with keep transform, then unparent your mesh with clear parent inverse. (Merely clearing with keep transform won’t remove the hidden inverse; merely clearing with clear parent inverse may leave your model with an inappropriate transform.) You’ll probably find that your mesh object has some scale value. Apply scale with ctrl a → scale.

Now reparent your mesh object to your armature object, probably with “armature deform”. Make sure Blender didn’t make two armature modifiers on the object’s modifier stack. If needed, restore armature keyframes from backup armature. Should be good.

Wow! Super! Thank you. I am trying this.

Ok, I am not doing something right. I select the rig (object mode) I use alt g >(location), Alt r >(rotation), and alt >
(scale)…but now the model follows the rig/bones and stands on it’s tail…Hmmm…How doth this Blender issue work correctly?? I didn’t know alt g…etc was for clearing…nice to know! But it is rolling the animal (crocodile in this case) back to it’s shape of origin? maybe? I am not sure as I inherited this model.
Ok, I reopened this file. start again. I cleared the parent keeping transforms.
When I try Armature Deform to re parent, the model jumps to humongous sizes again…and stands on it’s tail. When I un do and try parenting with Automatic Weights the model jumps to enormous again too…
Probably built in another program and with a different axis.
And my Mother says I better figure out my “parenting issues” before I come visit her again. :wink: hee hee hee

Sounds like you need to apply rotation as well (at the same time that you apply scale.)

The armature and the object need to have the same rotation and scale at the time of the parenting, and the armature needs to be at the world origin (reset position.)

I tried to clear parent, hang on to transforms. I tried to apply transforms, scale and rotation separately. I didn’t get any response and in a different order the mesh hopped to being huge. I am not understanding something…what would this be? I know if I deal with parenting I need to select mesh first, rig second. But to alt A… or apply ?? DO I select mesh, hit Alt S or Alt R or Alt A…and then hit Enter? or …Apply Transform check box? Hmmm…I just re opened the file and only selecting the mesh I hit Alt A…and I got a menu I hadn’t seen yet.
So I chose Apply Transforms.
It seems to me that I am in a wrong mode or setting when i try to set or apply transforms…so much to learn. You probably don’t know how much you know! And thank you for giving me a hand! Really, thank you. Bandages, Your responses are very helpful even if i haven’t gotten the mesh to move via the rig yet. I am still stumbling.

I cleared parent keeping transforms. Thank you Bandages. I alt+A, applied to each, mesh and rig, separately. I reParented envelope weights…I try moving the root bone in pose mode…


The rig moves up but the body ~ mesh stays at the origins. The bones do not affect the mesh.
When I cleared parent, the crocodile mesh name hopped down the Outliner… away …separate from the armature/rig

It looks like the rig got ruined on the way. All the bones were unconnected (not normal especially for the tail arms etc) and pointing the wrong way. If it was imported from another program I think the bone axis’s were not the same as blenders. Note that all the tail bones point upwards that is silly.
I am sure the rig should look more like this:


My advice would be to make a new and better rig!

In that file, the crocodile has no weights. It is not connected to the armature in any way except raw object parenting, which is pretty useless. It’s also screwed up in the ways I described (inappropriate transforms for the parenting relationship.)

  1. Unparent crocodile.

  2. Select both armature and crocodile objects. Apply rotation and scale.

  3. Parent crocodile to armature with empty groups. Weight paint the crocodile.

You may find it easier if you edit the armature. Its current layout won’t get you good automatic weights, but an edited version probably will. You’d basically just have to rotate the bones around their origins; doing it to eye would be fine (the tails of the bones don’t matter as much as the heads.) DNorman is probably right-- the rig is probably accidentally screwed up, possibly as part of an import script-- Blender’s axes choices are kinda non-standard, so that kind of thing gets bugged frequently.

If you’re comfortable wtih Maya, you should probably be using Maya instead, particularly on something that’s maybe not even native to Blender?

1 Like