Bad! I saw to many forest instead of trees!
I customized once my shortcut list and delete the shift+x key for the objectmode.
Now everthings works fine!
Thank you for the fast reply!

I can’t for the life of me figure out how you are bringing up the menu where the contain feature is. How do you do that?


1 Like

F6 or at the bottom of the Toolshelf (for me).

Perfect, thank you! F6 works for me. Fantastic tool by the way!

For me the F6 parameters from ‘Plug’ (deformation, contain, etc) didnt work on my blender install (they dont affect anything when parameters are touched). So i tried MeshMachine on a clean portable install, as result F6 parameters worked great. Then on that same install I added my addons little by little, until I noticed F6 parameters by ‘Plug’ stop work again.

Luckily I tested ‘Plug’ every 4-5 addons install, so short story short:

the culprit was Blender Light Studio <<<<.

If Blender Light Studio is active from user preference, then ‘Plug’ F6 parameters dont work; otherwise they work as intended if BLS is disabled from user preference.

That quirk need confirmation: fellow MM 0.6 users could install BLS to confirm the issue?

It’s not the F6 key that is the problem, it’s that BLS maps the x key in object mode to a custom delete operator, thereby making the MEShmachine menu inaccessible.

It’s pretty poor form to override a default keymap without giving the user a way to adjust that behavior, IMO.


  1. deactivate MESHmachine, an re-activate, save prefs. This ensures MESHmachine maps its menu to the x key after BLS
  2. choose another key for MM, before activating BLS

Please confirm, if this is your problem, or if you really have another issue with F6.

Peetie do installing any of these files in your modules folder help for DecalMachine? Which files do you put there?

I found these files in one of my zip files of 2.79b. I put the extensions_framework file in my scripts/addons/modules folder to get chocofur model manager to work. I am just going to determine if I should add the other three files by my install dates. By install dates it appears the 3 py files should go there as well. As far as I can see.Thanks

In Blender where DecalMachine is working there are no files in Modules. (Yes a folder named PIL, but that’s not for DecalMachine, forgot what that was for).

In weighted normals build, I find indeed the three python files, but not the extensions_framework.

Maybe it’s just a problem with a keymap; got no error message at all, keystroke D doesn’t simply do anything in the weighted normals build.

Did you look in your modules folder in “scripts/addons/modules,” not “scripts/module.” As far as I can see the extensions framework file needs to be in “scripts/addons/modules,” as in the picture. Like I say to get the chocofur model manager to work I also needed the extensions framework file. Initially I made the mistake of putting the extensions framework file in my “scripts/modules” folder.Thanks

I placed the folder extensions framework in the folder you mentioned for the weighted normals build. That didn’t work. Then in the weighted normals build I found out that for DecalMachine is no keystroke D registered for some reason. I can find back shift-Ctrl-Alt + scrollwheel though. Update: we are in a thread called Meshmachine, It looks to me we are polluting the thread here. Better post in other forum about decal machine or else.

See this post for how to get DM working with experimental builds. And yes, please post over in that thread.

I can’t provide any input on the cgstrive build as it’s windows on.

1 Like

That did the trick, thnx.

I’v tried what you said but sadly no result, BLS addon still give the same problem about F6 menu by using ‘Plug’.
Peraphs I am the only one with that problem (really, nobody else can confirm it yet?!?) but if thats not the case then it will a pain since BLS is not used by few.
So if you’ll receive reports describing the same problem I have, as first thing you should ask them if they’v installed BLS :grimacing: .
Jokes aside, changing the shortcuts didnt work for me. While I cant say if its an user error or “bad colliding” between MM and BLS, I can neither report it as a bug to you or @leomoon84 (BLS dev).
So, it seems I’m pretty f***ed :neutral_face:
Unless you and @leomoon84 cooperate a little to tackle that stupid issue in a clean way, but Im feeling stupid to ask it since nobody else hasn’t confirmed if that stupid quirk can be reproduced on other installs. What is the result on your Blender @MACHIN3?

Having some trouble installing the new version.

Downloaded the file, it had some weird long name.
Moved it to MyDocuments (for safe keeping)
Installed the addon from the zip in blender
Get this error:

Also tried installing .5 again and it works fine.
Edit, seems to work fine trying to install 0.6 over 0.5 instead.

Report it properly please. see

It should intall clean. I’ve tested. I’d always recommend against installing over a previous version.

I can’t see what blender version that is, but please report it properly, see

I just removed my folder and dump the new one in, so far, never had an issue :slight_smile:

That’s probably the best way tbh. It will definitely keep prior settings. It’s how I do it as well.

Other than that, a good way is to use the addon’s Remove button in the prefs first, and then install the new version. It’s possible this resets the addon’s prefs though.