Meshroom: Free photogrammetry

  • AliceVision should be built with Alembic support to use Meshroom.
  • Alembic is not required to use AliceVision (you have options to run the pipeline without Alembic but that’s not what Meshroom uses as we want to use standard file formats for interoperability, file sizes, etc.).
  • qmlAlembic is a viewer plugin for Meshroom and is optional.

Ok, this is extremely good and fun.
As I had mentioned, I did the test with “MirebeauStHilaireStatue” photos from this GitHub repo:


Here one of the photos:
https://github.com/rperrot/ReconstructionDataSet/blob/master/MirebeauStHilaireStatue/DPP_0006.JPG

When Meshroom finished the process I was disillusioned with the result that Meshroom showed. But I imported textured .obj in Blender and Wow! Watch the video:

And this is with default configuration, I just pressed “start” button (anyway I do not know if it can be configured in some way, from GUI or from nodes)

In linux files they are saved in “/tmp/MeshroomCache”, so backup those files before shutting down or restarting the computer.

Awesome work @fabiencastan and other developers involved!

Why did it look bad within Meshroom?
In the 3D viewer you can display the sparse point cloud and the final mesh. If you have both enabled (which is the case by default), you cannot visualize the mesh correctly. Is that the problem? Or is there a real issue? If yes, can you share a screenshot?

“Mesh” item was displayed a little greyed out and when unchecked “SIM” I can not see anything. Did you say before that “qmlAlembic” serves to see the mesh?. Apparently I have not been able to export the variable correctly, I have tried these two ways without success:

This install it in “/usr/local/qml/AlembicEntity/libalembicEntityQmlPlugin.so”
For Meshroom I tried with “export QML2_IMPORT_PATH=/usr/local/qml:$QML2_IMPORT_PATH” or “export QML2_IMPORT_PATH=/usr/local/qml/AlembicEntity:$QML2_IMPORT_PATH”

Do you know how I should do it?

Edit:
Sorry, I had not seen “Load Mesh” button that appeared below.

@fabiencastan Is this normal to have the mesh flipped in the 3D view? Is there some setting to make it flipped upright by default?

Hello everybody!
I want to know, the installation version for Windows is already out?

I’ve had no luck compiling this for Linux (Mint 19, i.e. Ubuntu Bionic, I guess). So if anyone has compiled binaries and could share them it would be much appreciated!

Looks like the first release is available.

2 Likes

Thank you AliceVision:grinning:

Looks really promising, but I only get crash upon crash at the moment…

Using their supplied windows build, windows 7 64 bit OS

1 Like

so do i (win build + win 7 64b)

look likes it running well in Debian linux (testing) , it still computing my first reconstruction test, I’ll tell you if I’ve got issue to get it into blender …
Anyway, thanks a lot it looks like an awesome tool !

It seems that the windows version(tested on win 10) doesn`t show the mesh in the viewport?

The results from Meshroom are imo astonishing - considering the bad camera Olympus VG-120 which was used.

Meshroom Result:

Same image data but with Agisoft Photoscan:

here the meshroom output with some additional light.

Thank you very much. Really appreciated.

Tried the window build but it seems there is something it doesn’t work.

I’ve followed the youtube video with meshroom demo but after pressed the “compute” command, I can’t see any 3d point and log seems says “running” (forever).

I used both this images https://github.com/rperrot/ReconstructionDataSet/tree/master/BurgosPuertaDeLaCoroneria and one set of mines.

There is something I should check different from the youtube video demostration?

Thank you for your efforts!

@SterlingRoth and @Rimasson create a issue on github. I haven’t tried the windows release build ,but I have no trouble with it working on Windows 10.

1 Like

Issue sent. Thanks a lot for your work.

What’s the minimum number of photos to recover correct camera position ?

I found some photosets from agiscan to crashtest meshroom
http://www.agisoft.com/downloads/sample-data/

Loading a set of images, I hit start, it takes some time.
After, I get many camera positions in the 3D window.

There is no 3D-Data generated? Trying ‘recompute’ on meshing node. Still no 3D-Data.

Starting Meshroom with CLI I get …

QOpenGLShader::compile(Vertex): 0:1(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, 3.00 ES, 3.10 ES, and 3.20 ES

Ubuntu 18.04. here.
Not sure how to resolve this.