Mesh's Look Strange in Object View

Hi all,
I’ve managed to get to the end of the gingerbread tut in the Blender 2.3 Guide but there’s something that’s been bothering me for a while. I can just ignore the problem and carry on but I’d prefer it if I knew how to solve it.

My ginger bread man’s body looks like this in design view:
http://i61.photobucket.com/albums/h72/soapyfish2006/100506.png

If I want to see it properly I can select it and then go into Edit mode and it looks like this:
http://i61.photobucket.com/albums/h72/soapyfish2006/1006062.png

I just wondered if there’s any way of getting it to look like that in design view (or is it set like this on purpose to make navigating in design view less confusing)?

Thanks in advance. :slight_smile:

Its to speed things up with heavy meshes.

use the SlowerDraw button in the mesh options (F9).

Looks nice, btw! (also nice to have a well written question!)

when in edit mode enable “all edges” on the mesh tools panel. When not in edit mode then you’ll see all of the edges

Thankyou for the help. :slight_smile: