Messed up my Blender Render after using Cycles Render

I was trying to take advantage of the better lighting and cool effects that cycles render seems to supply, until I realized that I couldn’t include a movie on a screen(created an iphone to show off a new app). So I took off the newly applied materials under the cycles render and assumed that everything would be back to normal when I went back to blender render. Now it looks like this:


Does anyone know of a setting I may have forgot to uncheck, or where I may have went wrong?

Cycles based materials use the node feature. When you return to Blender Internal, the material node switch is left on. Some times that will produce vacant materials. Re-check your materials and make sure the node button is off, unless you plan on using node based materials in BI as well.

Also, I’m pretty sure you can use movie textures in Cycles now.

Thanks. Not sure exactly where I did this. It’s in the world tab, correct?

Really? That would be awesome and solve my problem, but I havent been able to find a walkthrough on how to do this. Any idea on where to start to make this happen?