Metaballs to Alembic and back : Blender 2.79 & 2.8 alpha (eevee) workflow

Creating a fluid like effect using metaballs

3 Likes

I love your tutorial but have a bit of a problem right at the very start.

I can’t seem to export my metaballs as an alembic cache. It does not throw an error but it ends really quickly, the progress bar goes to 1% and then it quits. An alembic file is actually generated but its just 623kb. I’ve made sure to use the latest 2.79 version for this and still no dice.

Here is the file: http://pasteall.org/blend/index.php?id=51409

Its just the metaballs, the paths and the camera and I make sure to select the metaballs and only export selected. If you have any idea’s what could be causing the export to fail I’d love to know. :slight_smile:

1 Like

I’ll check it out now…

1 Like

Hi, all you need to do is add a keyframe to Mball (the one not following a path) … in your file I keyed the scale at frame 0 and again at the end frame… no need to change the scale or anything… and it worked fine… would love to see your final result if can post it here :wink:

1 Like

First of thank you for taking the time to trouble shoot my blend!

At first glance just keying the main metaball object does not seem to make Alembic work. That said I am really pressed for time right now. I’ll make certain to give it a good look later on and let you know whether it solves my issue or not. I certainly hope it does!

When I get blender to play nice I’ll definitely post the result here. :slight_smile:

I’ll just check it again… and make sure.

1 Like

Yup… 100% I just downloaded keyed at frame 0 and again at the last frame… exported\imported and it works!

I’m using the 2.79 build from here : https://builder.blender.org/download/

FYI : The exported file should be 43mb for your scene.

1 Like

I am really sorry, but I still cannot get it to work.

What I’ve tried:

  • Keying the main metaball object
  • Using 32 bit version of blender instead of 64 bit (I am on windows 10)
  • Reinstalling blender
  • Disabling all addons
  • Removing all spaces from path to blend file and alembic cache
  • Exporting to different HD
  • Exporting to root of HD
  • Appending metaballs into a clean blender scene

Alembic export works just fine if I use it to export a cube with a simple deform modifier.

At this point it looks like there is just a bug with metaballs export to Alembic and my local system (be it hardware or software). It won’t work in 2.79 and it won’t work in 2.8

Thanks for giving it your best shot though. I appreciate the effort! :slight_smile:

Well it looks like you’re tried literally everything :frowning:

The only difference I see is that you’re running 32bit win10 and I’m running 64bit…
I have a bug report in for 2.8 as it really doesn’t want to play nice with this for me…

I’ve uploaded your the way I have it set up right before export just as a last effort… the only option you have left after this is to boot Ubuntu off a USB key and try from there… maybe consider making a bug report…

metaballs_279(last try).blend (509.5 KB)

1 Like

Here’s your alembic file so you can finish the tutorial :wink:

https://drive.google.com/open?id=1Bfg9KM7lqr5w7aW0R_Ffz3g_6hMJ7L08

1 Like

Yeah I did try everything. Well apart from booting ubuntu that is :sweat_smile:

I tested 32 bit in addition to 64 bit which I normally use btw. It shouldn’t make a difference but I was getting pretty desperate.

I did try the blender file you prepared for me but regretfully its the same deal; ~600kb alembic file on export. At least I know for certain its not my process now! :wink:

I see you have already submitted a bugreport for 2.8. Let’s hope they are willing to fix it at some point.

1 Like

Cheers fin! I really appreciate all the effort you’ve put into helping me.

I’ll go play with it now, the metaballs are pretty boring without any noise on them so I look forward to giving them some life! :slight_smile:

1 Like

No problem… I was beginning to worry for your sanity… happy blending :wink:

Thanks. Great tutorial. I started to do this because of shader. But It’s impossible to make it from video. It would be amazing if you share it with us.

1 Like

Hey Pavel, welcome to the forum. :slight_smile:

I managed to replicate the shader, or at least I think I did. :sweat_smile:

image

I assume Fin won’t mind if I share it since he shows in the video how its done.

http://pasteall.org/blend/index.php?id=51411

No guarantees I did it correctly though because I can’t say I understand everything that’s in there. :thinking:

Post what you make when your done. I am still working on mine but Ill post it soon!

1 Like

Thanks! I will try it.

1 Like

Looks good to me… it’s a weird shader… some logic and lots of nonsense… it’s really down to hdri manipulation… thanks for sharing it…

1 Like

Haha! Thank you for sharing it :wink:

I know your shader is not ‘correct’ but damn is it pretty. I am well aware how games look nowadays but the fact I can play this stuff back realtime while using all of blenders animation, modeling and shader tools still feels like magic to me.

I normally don’t do motion graphics but this really motivates me to play more. :slight_smile:

1 Like

I got motivated to do more with this today… this what I came up with… eevee too…

1 Like

Wow that looks wonderful again. The music goes very well with it too. :smiley: I love your colors! I’ve only recently been learning how color works. Primarily using this: http://www.tigercolor.com/color-lab/color-theory/color-theory-intro.htm

If you have any tips on color, a website, book or anything really I would really appreciate it.

Here is my metaballmagic™:

There are some things I will improve still. Volumetrics work properly now where stuff in the front is clear and stuff in the back gets a little tinted by the volumetrics. Took some fiddling but worked out in the end.

The point light is really hard to get to behave though. In your tutorial you use it as a sort of natural vignette. It lights up the volumetric environment around it creating a halo. I could not get mine to behave similarly. I am certain its a matter of experimenting though, I am close. :+1:

I also feel my colors ended up a little washed out in the final video. Do you use results straight out of EEVEE or do you always do some post for levels and other final tweaks?

Anyways, learned a ton and had fun so thanks again. :blush:

1 Like