Michelle - and Meshdeform modifier

Hi there!! Meet Michelle - my favourite mouse. You can see a render of her here. Yes, I know, she needs a hair do, but that’s not quite the problem.


Michelle has an armature, and also a cage mesh for a MESHDEFORM modifier. The problem is that when I move her along the Y axis say, the mesh moves uniformly - but the fingers distort badly.
Here’s a screen dump of Michelle at the default position.


and here she is after she is dragged in the Y direction.


One point to note is that the fingers are controlled by the armature and the palm of the hand is controlled by th MESHDEFORM modifier.
If you can suggest why this is happening, and possibly think of some clever way to solve this problem, I’d be very happy.
The Blend is here–


but note it’s a largish 10MB+ file, due to the modifier.
Regards to all Blenderers

Hi MarkZ,

I have been struggling with the same problem the past couple of days and I’ve only just now discovered what needs to be done, although I don’t know why just yet.

Here are the steps I took to make this work:

1 Create mesh-object (= hi-res mesh)

2 Create mdm-object (= low-res mesh deform cage)

3 Create armature

4 Create vertex groups for mdm-object (= bone-names -> except for bones that will deform the mesh directly like the finger bones)

5 Add Armature Modifier to mdm-object : fill in name of armature and select which deform you want (I only use Vert. Groups) --> here Multimodifier needs not to be selected

6 Create vertex groups for mesh-object (bone-names -> for all deform bones AND a vertex group that is not assigned to a bone and comprises ALL vertexes : I called it “allverts”)

7 Add a MeshDeform Modifier to the mesh-object (fill in name of mdm and for the rest I kept the default settings)

8 Add Armature Modifier to the mesh-object (and here are some important settings!!)
8A) fill in name of armature
8B) fill in name of vertex group (Remember 6 above? I called it “allverts”) !!
8C) Press the “Inv” button !!
8D) Select which deform you want (I only use Vert. Groups)
8E) Press the “MultiModifier” button !!

9 At the end you can press the “Bind” button of the MeshDeform modifier and the MeshDeform modifier should be ABOVE the Armature modifier for the mesh-object !!

This should do the trick.
I didn’t get it to work until I found out that the mesh-object needs to have a vertex group that has ALL the mesh-object vertexes assigned to it and that in the Armature modifier it should be inversed as explained above.
I’m going to try and find out why this needs to be like that because at this moment I don’t understand why and how it works like that.
The reason I tried this is because I took a look at the Chinchilla blendfile of Big Buck Bunny.

I’m sorry that I didn’t get a look at your blendfile.
If I have some extra time I will try to do so.
But I think if you follow the steps I described, that it will work out for you.

Let me know if there’s still some problems.

See you, Dominiek.

OK, I took a quick look at your blendfile and you definitely need to do what I described above, including adding vertex groups for ALL deform bones of the hi-res mesh as I described in point 6 of my previous post.

Right now, I only added a vertex group “allverts” to the hi-res mesh, filled the name in and pressed Inv-button and pressed the MultiModifier button (see point 8 above), and then it worked but not for the parts of the hi-res mesh that also need vertex groups!

Hope this helps …

Right off the top of my head I’d think you forgort to assign the fingertips to a bone, but you say this only happens when you move her on the Y axiz, not x or z?

MarkZ, putting images on Mediafire adds extra steps to anyone interested in your thread. You can add images (and blend files) as attachments to your post directly, scroll down to the “Manage Attachments” button. That way people can see what you’re talking about without having to open another window and download and then open the downloaded file.