Middle Mouse Click Is Sticky while Bound to Wacom Pen

Hello, I’m having a simple but frustrating problem that’s really hard to google because it’s so specific and everything that comes up when I search for related terms comes back with “Middle Mouse Click not working” or something similar.

My issue is simply that when I’m using my Wacom pen buttons to middle click to turn and move the camera, sometimes it releases the camera when I let go of the button (as it should) but sometimes, seemingly randomly, it’ll keep moving the camera even though I had released middle click. Can anyone help me solve this issue? It’s very frustrating and causes me to make a lot of work flow errors constantly because I don’t know whether I’ll need to click middle mouse on my pen again or not.

I’m using a Wacom 27QHD, Blender version 3.1.2 on Windows 10.

Welcome to BA :slight_smile:

You’re probably not going to like this suggestion, but have you tried changing the batteries in your stylus?

The pen doesn’t use batteries.


Cintiq styluses have no battery, IIRC.

Two things come to mind:
Sometimes there are problems with a new Wacom driver. Have you recently upgraded? Try downgrading. If not, uninstall/reinstall.

You might like this even less – after several years of use a friend of mine had a thin wire inside the connecting USB cable break and that caused intermittent problems with clicking; it was really hard to diagnose, too. Is it only ever the middle click, or does it have other occasional issues? How old is your tablet, and how much strain is that cord under? Can you easily switch it out to try, or is it attached to the tablet?

I’d try these other standard remedies (just listing the lot; you might’ve tried some already):

  • Cold-booting your computer.
  • Unplug from the USB port you’re using and try another one.
  • Does it happen in other applications where you have bound that key as well?
  • Can you try to use the tablet on another computer to see if it happens there too?
  • When the problem started, had you installed/upgraded any software? Deactivate to see if that fixes the problem. Or Windows upgrade? Umm. Rolling that back is a bear, I’d put it off til last. There are potential problems with certain Windows settings, I’d look into those first if it comes to that. Like, disabling Window Ink for the time being.

Wacom support forums, where you might get further help: http://forum.wacom.eu/index.php

1 Like

This is a unique problem in blender. I’ve used my tablet professionally for years, never had an issue with using it.

I believe it’s a software issue because if the situation occurs I can take my stylus away from my tablet and then continue to move the camera around with my mouse without middle click held and the pen too far away to register an input. I have to middle click again to get the out of rotating the camera.

When trying to replicate it just now, it didn’t happen until I started holding down modifier keys to zoom and pan, then it stuck when I did it to rotate. Might just be a coincidence though, I’ll continue to try to actively replicate it to see if there’s anything making it happen that I’m not noticing.

Important discovery: It occurs everytime I middle click using my Stylus button while my stylus is touching the screen, but never when I’m hovering the stylus. For science I tried to replicate it by holding the stylus to the screen and middle clicking with my mouse to see if the same thing happened. It did not. It only happens if I middle click via the stylus button.

YES! Like you’ve toggled it on and it needs a click to turn it off. Not using a cintiq but am having this same behavior.
I think it has something to do with moving outside the viewport: it won’t reactivate when you go back to the viewport.

I wish I started sculpting earlier so I could’ve shared what I found earlier. In case you didn’t find a solution or other people need it:

I was just getting started with sculpting and immediately ran into this roadblock, but I think I found a solution.

In the wacom tablet properties, try changing the button settings from hover mode to click and tap.

1 Like