Millimetric paper material - Box project?

Ok It worked out. Maybe I was tired and missed something.

I did need to check in the first Cross product node the value of the second vector to 1 on Y so, no 0,0,1 but 0,1,1

Thank you a lot

1 Like

That is what you want? The paper looks like random lookup. The keyshot example in OP, although probably suffering from stretching due to nature of triplanar mapping, appears ordered - cut from a continuous (as much as possible) piece of paper.

Did you try the paper unfold method that was mentioned? When nothing is continuous, it doesn’t really sell the idea to me that this was made from a sheet of mm paper.

It worked with the UV technique. Now it looks all kind of seamless.

I am trying to follow this technique:

but it is not working with my rocks.

The only two options I can think of are:

  • Box (images only) / triplanar (procedurals also) mapping which does introduce stretching and you may have to find an origo orientation that makes the least amount of issues.
  • Unwrapping for least distortions, and placing seams with sync and live unwrap enabled. In the image I’m showing a nearly perfectly unwrapped stone, but there is one edge left I need to mark as seam to avoid the stretching indicated with the arrow. When I add that selected edge as the last seam, I should be able to cut out the UV layout from a sheet of paper and fold it into a stone (minus the glue edges of course).

    The stone on the left is triplanar mapped - less manual work required but may fail in some cases.
    Stone on the right is manually unfolded by adding seams in synced live unwrap mode.

Edit: I was able to find more faces with stretching in them, so more seams was needed. But you get the idea. If a face separates into a separate island in the UV layout, mark an edge and clear the seam.

1 Like

I think the triplannar looks less time consuming. Is it possible to share the node setup for tri-planar?

Thank you so much for taking the time.

Just another way, using UV Islands…

Thank you , the problem with this option is the discontinuity between the grids. It is quite noticeable, the lines do not touch the end of the face right?

Yes, you are right, in that case @CarlG 's solution looks like a better one…
There is another way…using these nodes and that is to set the texture coordinates from UV to Camera, and connect to Vector on the Mapping node…the texture will always be pointing to the viewer…I think it looks a bit strange though, like a Projection instead. But might be something to look at in the scene…

One really janky hack is to bake a single UV square to a float exr texture then box map that texture to the mesh and use it as the vector of the bricks, You can box map anything with that method

Just to try this, what do you mean with the uv square bake? I am sorry I am not super experience in this.

Here I baked it out for you

UV.exr (4.5 MB)

Here it is on your model

Stone.blend (4.6 MB)

Its important that you dont have interpolation on it so set linear to closest, Oh and use generated coordinates not object or you will get seams

1 Like

This is fantastic thank you so much, I am testing it soon
Thank you so much

1 Like

Hi! I am not sure why , totally different outcome here. I have a small cross in the center of each square and also the lines are all washed out and jagged.

Any idea what I could do ? I am doing exactly the same you posted

Ok , found out…it does not work in eevee

It does work in eevee, Are you using generated coordinates. I can see you are using linear interpolation on the texture that needs to be turned to closest, the file i sent works with eevee… Oh and you are using generated. set that to single image

This is strange, but I am using the file you posted …and also does not show the outcome of post …maybe is my blender.

Edit: I changed to Object and worked out now :slight_smile: but the file I got was in Generated

Well I can download the file and see its not on generated. Maybe a blender bug? im on 2.83 daily build, True boxmapping is generated coordinates not object

Have these settings exactly


Must be a bug…I will try with Blender 2.83 now…

Wait plug this directly in here and lets see if the mapping is working at all