Mineblend - Blender importer add-on for Minecraft worlds


(TAMcCullough) #21

P.S.

How come nobody has posted any images yet?


(jbeyta) #22

Thanks, it worked great. I didn’t zoom out enough


(swepower) #23

Hi, Can you make it possible to select the .minecraft by hand? Im not having mc installed but i do have some backed up .minecraft folders that i would like to test it on.


(Equip) #24

I don’t know what I’m doing but I managed to get this up.



(A'nW) #25

Glad you liked my pictures! They were fun to make, but yes, arranging those blocks in Blender…
The blurry texture problem is actually very easy to “fix”, just switch off texture interpolation. Here is a quick picture I did to illustrate for further clarification.


That should fix the alpha problems just fine also.


(rcpongo) #26

Very happy to see this. The dupliverts method is very nice for editing too.

One small request would be an option to only load the layers that are above the water level, or even an option to load a range of layers. That should help quite a bit on performance when you don’t need all the underground stuff.


(Michael120) #27

I just downloaded on of the pre-releases(Pre-release for the new 1.0.0) Jar from Minecraftforums.net(they shared a link), put it in %APPDATA%/.minecraft/bin renamed it to minecraft.jar and it works fine :wink:

Also, once you put that in there, it loads everything great. One question though; why does it only load the part your near, and not the whole map(Probably for obvious reasons(too many blocks), but…just wondering :stuck_out_tongue:


(A'nW) #28

The reason it doesn’t load the whole map is definitely the poly count that would result. I have been messing around with it (it works great for me) and here are the stats for what I currently have loaded. For the four (only four!) chunks around my save point at sea level and no stone their are still 575,262 verts and 383,508 faces.


(jbeyta) #29

Here are a couple of Cycles renders using this. It works well.
http://www.joelremigioabeyta.com/images/mineblend.jpg
http://www.joelremigioabeyta.com/images/minecraft.jpg


(Atom) #30

@jbeyta: Those look great.

Minecraft is a game, right…? Do you need to have the Minecraft game installed to use this script? Or is there a place where you can just download levels?


(JustinBarrett) #31

yes it is a game, very addictive too…well to a fault…and I think you just need the save game world…it saves each single player game as it’s own world. You are better off trying the old free version…
got to


and in case links are still not allowed…
http://www.minecraft(dot)net/


(stickfigure) #32

I’m unable to choose any world in the menu. I’ve looked at the path, and it should be right. Anyone have any insight on how to fix this?


(Atom) #33

Thanks for the link. I tried the java based free single player but it has Save Level greyed out. I don’t understand the point of the game. Do I have to accomplish some goal for Save level to work?


(liero) #34

it’s a fun little game, I think of it as a simulator, the world generation algorithms are fantastic… there’s a survival mode and a creative one

here a little test that put my pc to its knees, maybe the option to import just a layer range would be a nice addition… and the cycles ready texture pack for sure, it looks a bit dull with just colors :stuck_out_tongue:

http://img254.imageshack.us/img254/7349/villah.jpg


(acro) #35

Hi everybody,

Sorry I didn’t get a chance to reply yesterday. On the add-on’s google site I’ve updated a new version “1.1” which hopefully fixes path locations on OSX, and also, addressing kar-re’s comment, adds pretty much all the new block definitions up to Minecraft 1.0.0. Quite a few texture face assignments are still missing at the moment, (notably giant mushrooms), and I do aim to fix these soon. Coloured wool is still not fixed (it was working in an old dev copy I had and will be brought back as soon as possible).

@TAMMcCullough - aha! it’s because (I’m an idiot and) it’s not playing well with Ubuntu. Sorry, I now know exactly what’s wrong, I will post a fix within the next few hours.

@swepower - custom .minecraft folder location. Sure, that sounds useful for readily opening backed up / saved out locations.
What would you prefer –
a. Look inside a custom .minecraft/ for bin/minecraft.jar (for textures etc) and saves/*
or
b. the custom location of a ‘saves’ folder? This would ignore textures and do away with the dependency on having minecraft.jar available.


(acro) #36

@A’n’W - rassum frassum could’ve sworn I disabled interpolation option! Thank you, I’ll test that out and roll it into the next update! Next question (related to the possibility of auto-loading Mobs from the saved games) how did you create Steve in Blender with the correct proportions? I think a .blend ‘model pack’ could accompany this script, and load in spiders, creepers, pigs, cows, what have you. Maybe. I haven’t given this feature much time or effort yet, because the idea of python-generating the models seemed extreme, and I dunno how accurate hand-made models would end up being.

@rcpongo - The short answer is Yes!, and to be honest I’ve been meaning to add that for a while (incredibly useful during testing, yet I didn’t add it! why? I don’t know!) A range of layers will be helpful, I just need a nice way to enter the stop and start layers, but yeah, I should be able to get added very soon. For water level, I would load a couple of blocks below that just to be sure in case of edges around other blocks sticking into the water surface.


(acro) #37

@jbeyta - your renders just blew my mind! Very nice! I very much want to add default Cycles materials (rather than just the basic diffuse colours it picks up at the moment). I think if I tweak the texture settings they should work quite easily in Cycles, and using some basic mirror reflection on water surfaces is one of my definite personal goals to try with this.

@liero - Another awesome image! Did you just replace the Long Grass instance block with a billboard (or something a bit more detailed?) It looks good, although obviously it’s a shame the rest of the blocks don’t do justice to that level of detail. I think this nicely shows some of my vision of how renders from this script should start to look once more of the block types and textures are handled with more surface info.
I am working on fence, stair and crops meshes, so those villages should look better soon!


(acro) #38

Stickfigure - hi, thanks for trying the script. I can only answer based on the detail you provide - you’ve said your path is right… a little bit more context would help with diagnosis. What was the path? What operating system are you on, and is there any ‘Traceback’ error messages in the Blender console after you bring up the Import > Minecraft dialogue? (the system console is usually off, but can be seen in Help > Toggle System Console.
All the best!


(Sciman) #39

I’m not sure if this is related to Stickfigure’s problem, but I got the path wrong for OSX. Turns out python already handles spaces, and so the escape character in the path isn’t needed. That and the slash before Library also needs to go, apparently the path.join command assumes the slash means absolute directory, and overwrites the path it is joining with. The line that seems to work for me is:

MCPATH = os.path.join(os.environ[‘HOME’], ‘Library/Application Support/minecraft/’)
MCSAVEPATH = os.path.join(MCPATH, ‘saves/’)

The MCPATH in blockbuild.py also needs this change.

That should fix the path stuff for OSX. Hopefully.


(rcpongo) #40

Thanks for the update. Will try it out tonight when I get home. I was missing a few blocks on my last import, so hopefully they are in there now. (I use glowstone for lights, and they were not in there last night)

The layers thing will be really helpful if you can get it in there,… my scene had something like 3 million vertices before I started removing the lower levels manually.

One more question: If I turn up the radius to something like 10, it processes for a while, but does not appear to bring in any duplivert mesh. (the material cubes are there) Is this a running out of memory issue? (I have 16 gigs on this machine, so it can usually handle large loads.)