Minecarft Animation

Hey,

I’m new to Blender/AnimationMac’s.
When importing the Rig File I noticed it was blurry. In a tutorial I watched the person just unlicked “mipmaps” and it became clear.
This did not work for me, so I tired it on my PC and it worked.
Then I went back to my Mac and made sure mipmaps was unchecked —> tried opening different files, same thing its blurry.
Anyone know how to fix this on Mac?