Minimaps problems

I want to not have minimaps in the .exe and blend but it puts the minimaps back on. And it isn’t my graphics card.


I’ll search. . .

I use 2.49. :\

That’s one of the reasons to upgrade - most everyone’s using 2.5, so more and more people will be able to help you with 2.5 code, and less and less with 2.49. Also, the new resources would be made in 2.5. Anyway, here’s an untested version for 2.49:

# Disable Mip-mapping Preloader for 2.49
# Author: SolarLune
# Date Updated: 11/14/11
# This script and preloader scene can be used in any capacity - commercial, freeware,
# hobbyist, educational, etc., as long as you attribute the author, SolarLune, with its
# creation.
# By using this scene, script, or any part of it, you agree to attribute the credit to
# SolarLune. This license agreement may not be edited or changed.

import os
import subprocess

cont = GameLogic.getCurrentController()
obj = cont.owner

thisexe = os.path.join(sys.path[0], sys.argv[0])                    # Get the path to this exe (the standalone executable)

nomipmap = 0

for arg in range(len(sys.argv)):                                    # Loop through the arguments of the program running, and look for any one that says, 'nomipmap'.
    if 'nomipmap' in sys.argv[arg] and arg != 0:
        nomipmap = 1

if nomipmap == 0:                                                   # If 'nomipmap' isn't in the arguments of the program, then it hasn't been enabled.
    subprocess.Popen([thisexe, '-g', 'nomipmap', '=', '1'])         # Restart the game and disable mipmapping.

    GameLogic.endGame()                                                 # End this game.

else:                                                               # No mipmapping has been applied
    sce = GameLogic.getCurrentScene()
    sce.replace(obj['beginscene'])                                  # And go to the next scene from the preloader

That should go right where the 2.5 script is in the preloader scene.