Mipmapping per object

I need to disable mipmapping for an object. Disabling it with python using from bge import render
disables it for the entire scene, it seems. And there are a lot of important objects that get affected negatively. Is there a way to disable it per object?

*I have such a small idea of what mipmapping means even after researching it. I just know it’s messing with all objects when disabled globally and only one object in my scene actually needs it to be disabled.

hi! You can have a look here: https://blenderartists.org/forum/showthread.php?393336-Enable-Disable-Mipmap-on-a-texture-(2-77)&highlight=mipmap

Thanks a ton youle! However, I can not seem to get it working. Can you check your blend to see if it works with the latest blender version? I tried it in your blend, didn’t see a difference- tried the code in my blend, and nothing has happened. I’m sure I’m doing something wrong but if you could take a look that’d be great.

I made a new .blend with 2.77a: http://pasteall.org/blend/index.php?id=43722 (we are in GLSL mode – if Multitexture, an option (I don’t remember which exactly) has to be checked in material tab)