Mipmaps are disabled whenever the game resets?

This also occurs in the Runtime… but MipMaps are enabled?! WHYYY!! :confused:
Here’s what it looks like before using the “Restart Game” brick:


Then when killing yourself, and having the game reset, you’re greeted with THIS:

I know a way around this is to “Apply material and textures” to the object,
but doing so makes them appear SHADELESS.

EDIT: Here’s what it looks like with the material, texture and the Blend mode set to “Mix”
I also turned off Specular, though it didn’t change much:


You’re going to have to explain more if you want some help, RandomPickle. I just tested this, and I don’t see any mipmap changes in my simple example file.

What shading mode are you using (GLSL or MultiTexture)? I’m guessing it’s MultiTexture, but I tested both and didn’t see any issues.

What graphics card are you using?

What version of Blender are you using? Are you tweaking the built-in mipmap settings in any way?

Can you make a simple example blend file?

What shading mode are you using (GLSL or MultiTexture)
Multitexture

What graphics card are you using?
AMD Radeon HD 6250

What version of Blender are you using? Are you tweaking the built-in mipmap settings in any way?
Still using 2.67b, and I have not

Can you make a simple example blend file?

Sure thing! Shouldn’t take too long

You are disabling mipmaps through Blender; therefore, when restarting the game, the launch parameters no longer exist. The solution: use Python.


bge.render.setMipmapping(RAS_MIPMAP_NONE)

http://www.pasteall.org/blend/30493
(pardon the large-ish file size, it’s more noticeable with bigger textures)

@MrPutuLips: How come it’s being disabled? I’m not doing anything out of the ordinary…
and is the script supposed to stop this from happening?

Okay disregard my post, I blatantly misunderstood what was happening. Looking at the .blend now.

EDIT: I have no clue why this is happening. Even when using


from bge import render
render.setMipmapping(render.RAS_MIPMAP_NEAREST)

it still sets mipmapping to none. I think this is a bug from what I can tell.

It’s happening to you as well then?
This has been going on to me for as long as I can remember.

I asked the same question a long, long time ago.
Back then, I decided to live with it, as the effect it made had fit well with the genre. (That was a different version of Blender, too)

Hm, it does appear to be a bug related to not having a material on the object (which isn’t a problem in GLSL mode, of course).

To bypass this issue in MultiTexture mode, use a material and set the texture blend mode to Linear Light.

(which isn’t a problem in GLSL mode, of course)
HEY, I’d use it if it didn’t make editing a living hell :wink:
One day I’ll get a decent computer…

To bypass this issue in MultiTexture mode, use a material and set the texture blend mode to Linear Light
Ahhh, that’s what I needed to hear. Works great!
Thanks a bunch you two, you’ve saved the day yet again!

Post-solved edit:
Spent the last day and a half trying to figure out why everything was still shadeless, (even after setting every textured object to “Linear Light”.
Turns out the Ammo/Health overlay counters were still set to mix. Took me a while to figure that one out