Mirror creating indentations

Hi all,

I was just playing around and making a chair when I came across a problem- I added 100% mean crease everywhere I wanted as a straight edge, and it looked great. The subdivision surface didn’t affect the creases at all. However, when I set the shading from flat to smooth, indentations appeared down the middle. Is there a way to smooth the rounded parts of the chair without the indentation appearing?

It looks like the smooth shading rounds all the edges of the chair, which is fine everywhere but the center. Is there a way to keep this rounding from happening?


Do you have a face inside the mirrored mesh ?
Have you enabled Merge in the mirror modifier and set an appropriate threshold
Where is your blend file ?