Mirror mod. Seam

Hello fellow blenders!

So i recently encountered a weird issue

I modelled a character with a mirror modifier. I made sure clipping is on and the subsurf modifier is below the mirror one - but i still have a weird ugly seam in the face of my character! And only there, the back is clean.
Please help me, i am so confused!

Thank you!!

Might be able to if you posted correct support files, just like requested in your previous threads.

Say, you had an issue with your car. Would you go to a car repair shop and say to the mechanic:
“Well, I hear a strange noise from the undercarriage. What can it be? Here’s a photo of the car.”

No? Well, but that’s more or less what you are doing right now.
As the mechanic would have to have access to the car, we will have to have access to the .blend file.

A screenshot is not a photo of your monitor.

2 things i can think of.

  1. There is an edge loop too close to the middle edge loop thus sharpening it.
  2. The middle edge loop is not aligned with the center of the mesh.

If it was number 1 you probably would have noticed, number 2 is a bit more subtle but still easy to fix.

  1. Select the middle edge loop
  2. Align it (S > axis > 0), the axis should be X by default.
  3. Move the edge loop to the center of the model until it snaps in place (if you have clipping enabled for the mirror modifier)

i see proportional editing is off. have you tried moving the vertice about so it sticks to each other?

@ ja12 and ikarishinji: guys, i would have posted everything, a normal screenshot and the blend file, my problem is that i currently dont have any way to connect my computer to the internet as well as to my phone. So i had to improvise :confused:
But i should be able to do it in a week, hope you would be able to check it out then, JA12.

@GrimZa: thank you very much for your answer! Number 1 is definitely not the case, but 2 might be it. I will check it out tomorrow!

@Sandradau: i switch it on and off, and yes i did try it :frowning: sadly no positive result…i also tried deleting faces and creating new ones doesnt help either :frowning: but thank you!!

That would be something to mention. “my internet access is limited and couldn’t upload files, and might not be able to reply in few days”, which is understandable but not without knowing that. So many play the guessing game with their questions and then don’t even come back to check their own thread, so it’s not wise to reply those kind of threads.

The problem with guessing is that even simple problems become difficult when there are many possible causes, and there usually are. Easier and more efficient to open a file and have a high chance of finding out what the problem is, usually in seconds or minutes at the most, rather than spend an evening listing all the possibilities, what relates to what, and how to check them.

Since your situation is different, here are few guesses:

  • Apply object rotation and scale. Ctrl+A -> rotation & scale
  • Edit mode, select all, W -> remove doubles, and ctrl+N for normals
  • disable mirror and delete all faces from the mirror plane
  • enable mirror, make sure the clipping is enabled on the mirror, and that it doesn’t use a mirror object which could be transformed
  • move the vertices that should be on the mirror plane along the set mirror axis and back if needed, they should stick
  • remove creasing from the edges on the mirror plane

If those don’t solve it, don’t reply with “it didn’t work” without the file. No one does anything with that information. There might be something else going on but those are increasingly harder to guess and explain.

Remove your subdivision modifier then add it again .

I am terribly sorry it took me such a long time - but I finally fixed my internet problems.
I tried everything you proposed - sadly with no luck.

I hope someone still might want to help me - I would be very grateful.
Here is the blend file:

untitled.blend (12 MB)

It’s how the structure is modeled. It probably seems smoother because you’ve enabled subdivision surface modifier visibility on the edit cage, and it doesn’t show the real vertex positions.https://blenderartists.org/forum/showthread.php?410365-When-to-add-subsurf-at-the-beginning-or-the-end-of-the-modelling-process&p=3120034&viewfull=1#post3120034

The face sizes don’t gradually change for smooth results all over the model. Structure flows (edge/face loops) could be better because there are turns which aren’t needed, there are long quads in some areas. A lot of geometry, but uneven density; The body could do with subdivision level 1 but parts of the head needs level 2, which adds a lot of unnecessary geometry.

Armature modifier should be above the subdivision modifier. Otherwise it deforms the subdivided model which is very slow.

There are shape keys already. Can’t change the structure and expect shape keys to work. If you make the shape keys again, could edit the structure more freely, but if you carefully smooth it out without touching parts shape keys influence, don’t need to start limiting those keys to vertex groups etc.

I used undo/redo to check the visible shape keys. In edit mode I used shrink/fatten (alt+s) to move vertices and faces along their normals. Then selected some areas and W -> smooth, repeat last (shift+R) to repeat it.

Wow, thank you so much!!
I carefully followed your instructions and video tut, and it worked! :smiley: I am so happy, thank you very much for your help!!