Mirror, Subdivision Surface and Smooth Gap.

I have the mirror modifier with merge selected above the subdivision surface modifier subdivided twice.
I have smooth shading selected.
This is what happens:

I hope you can help.

Too little info, You have not supplied a link to a blend file as you should be doing for ALL support questions.

Check your mesh for duplicate vertices, non merged vertices (clipping and merge limit), additional stray edges and faces

How do I supply file?

Put simply, the problem looks like it is caused by the vertices not ‘touching’. Turn on clipping in the mirror modifier and then (in edit mode) move the vertices together (or apart) until they hit the mirror. Then they will stick together properly.

Looks like you still have some vertices/edges on the “cut” side of the model. Incredibly well drawn explanation:

Also, you should enable clipping to make sure your center vertices don’t drift apart.

I hope this solved your problem.