Misplaced Selection point due to imported file

I have modeled a building using AutoCad. It seems that the .dxf/.dwg file formats can’t be opened in Blender. What I did was I imported the .dxf file in AutoDesk 3DS Max then exported it to an .obj file. The model became larger as I imported the .obj
to Blender so I scaled it down. Problem is, the Selection point within the object is outside the object. Therefore, I can’t scale it properly. Please see attached.

I assume you are using blender 2.5x. If so use Shift+Ctrl+Alt+S and select whichever option you want to change the objects center.

I tried doing it just now but it changes to Shear mode. Tried it using 2.49b and 2.5 Beta.

The hotkeys may have changed since the last version.

Select you object, then from the menu bar select Object>Transform>Origin to Geometry

Also, I think you need to be in object mode

Thanks, I figured it was Shift Ctrl Alt C.