Missing Background shader in Cycles?

I can’t seem to find the background shader in Cycles, for some reason. I’ve searched for it, double-checked my add-ons and even poked around in the internal rendering engine with no luck. Did the name get changed, or does the background shader no longer exist?

I’m trying to create a star-field background for an animated scene, and wanted see if I could avoid screwing around with skydomes/skyboxes and the like.

So, what happened to the background shader, and is there another way to get a good looking star-field background without having to resort to importing equiangular images?

In the node editor ensure you are on the World shader setting not a material shader or add nodes in the World settings



Show us what you see

Oh, that solved it, thanks. I was in the wrong mode.

Seems like its always the little details that trip me up…