missing edges in object mode

hey blenders, :wink:

when switching from edit to object mode im missing edges on my object…
see this image:

would you have any idea why this is happening ?
i didnt find anything about his in the search or in google…
…might be a problem of finding the right search-words though…

would be awesome to know why this happens… im a little afraid it could cause problems later…


Press N for the properties panel.
When in object mode under the Display tab select ‘All Edges’

awesome! thanks!!

i still dont understand why it this happens… but ok,… dont need to understand everything ;D

blender hides those edges, where faces are nearly 180° connected to each other, so that flat portions of a mesh look more like one single face, thus highlighting edges. some people just prefer that, some don’t, so there’s an option to enable/disable it :stuck_out_tongue:

If the two adjacent faces are planar it will not show the edge.