Missing Faces


(munkey_mike) #1

There seems to be a problem when I try to give my model a texture for gameblender. When i apply a texture, certain faces are missing, I can see through certain sections of him. What is the problem? Sorry I can’t post a picture.


(wes1) #2

use Two side :wink: in the paint buttons wes1


(saluk) #3

These faces are facing the wrong way. Either set all the faces to double sided mode (Select object, press f, press A until all faces are selected, go to paint buttons, choose two sided, and click on copy draw mode) which is bad, or select each bad face and switch its direction. (Select object, press f to go into face mode, find the bad face, press tab to go into edit mode, select the points that make up the face, press W, and choose flip normals. Then tab out and find the next evil face).

Also, in edit mode, if you select all the points and press either ctrl-N or ctrl-alt-N you can recalculate all face directions to be either facing outside or inside; but this doesn’t always work how you hope it will.


(munkey_mike) #4

Thanks for the help. One last question, will using the double sided option effect game speed?


(saluk) #5

Yeah, it means twice as many polygons that the renderer has to render.


(cluh) #6

Having the faces double-sided is doubling the faces so it probably does slow it down.