Missing GPU option for Cycles in 2.69-rc3 on Windows 7 x64

I have used Blender on and off since 2.5 was released and when Cycles entered the scene it got me really hooked! I have an old Geforce GTX 560 in my Windows 7 (64 bit) computer and while it’s not the hottest graphics card it is still a fair bit faster compared to my CPU when rendering in Cycles. I have Blender 2.68a for Windows 64-bit and it works really well. The other night I decided to test the latest “official” release candidate, 2.69-rc3 Windows 64-bit, and in that build I don’t have the option to use GPU in Cycles. I have the latest Nvidia driver installed and since GPU rendering is working in Blender 2.68a when using the exact same configuration I’m a bit puzzled… Am I overlooking something?