Missing Model in render window

In Blender, I have rigged and assigned vertices in a model, but when I pressed F10 it is not there. It is in camera view. I have tried these things and no luck. I still can’t see anything.
If you check your original file, see if the render output in the scene menu (F10) is set to Blender interal or Yafray - change it to Blender internal.
Go to edit mode. Turn on display normals and check that they are set to the OUTSIDE otherwise, recalculate normals
Check in the world settings that you haven’t got mist selected (next to stars)
I would really appreciate it if anyone could help me. Thanks.

perhaps check in the outliner and see if the render flag is turned off? (outliner is F9) and if so turn it back on

Other things that come to mind:
Make sure “Do Sequence” is not on in the Render panels (F10).
Make sure you have sufficient lamps in your scene.
Is your object transparent (Alpha = 0)?
Does the root bone have an IPO that’s making rig jump out of view?

[F12] = Render
[Shift] + [F9] = Outliner

I think slikdigit and CD38 covered most of the likely culprits.
Shouldn’t this be in one of the Support / Question type forums?

Sorry about being in the wrong forum. New to all this. I just dumped the lot and re-rigged the model and so far it is in the render window, so I think I must have done something or didn’t do something when I rigged in the first place. Thanks.

cool! let us know if you ever figure out what it was (but I’m glad it’s working now)