Missing objects in render


(Santiago) #1

Whilst rendering a scene, I noticed that some objects were missing. At first, I thought perhaps the objects were too close to the camera, and had been clipped. I dropped the clip value to as close to zero as it would go. No change. I tried moving the camera away from the objects, but this also had no impact.

Finally, I noticed that the objects which did not appear were mesh, with perhaps more detail than objects which did render. I’ve seen this sort of thing in other rendering programs, where it resulted from not having enough buffer.

I don’t know if such a thing is possible in Blender. I looked to see if there was some sort of buffer which might have this impact, but if one exists, I was unable to identify it. Can anyone offer some ideas? :smiley:


(VelikM) #2

1: Are the objects that aren’t rendering on a different layer than the lamps?
2: Do you have ‘Layer’ selected for your lamps (in the Lamps buttons window)?
3: Have you tried to move the object that isn’t rendering to a seperate layer with the camera and a lamp to see if it renders?


(Santiago) #3

Good questons, and food for thought. Yes, the objects which aren’t rendering are on a different layer than the lamp. No, "layer’ isn’t selected for the lamps.

I haven’t tried to move the object to a separate layer with the camera and lamp. That’s a bit complex (due to the nature of the scene), I will set up a test to see if this helps.

However, the things which aren’t rendering are pieces of an object. All of the object is on one layer. Some of the pieces render, some don’t. One of the things which does not render is the head and facial features. One can apparently see through the head to the inside of the object’s hat!

I did notice that removing subsurf on the head made it visible. That’s part of what got me on the idea that buffer space might be involved. However, objects on the head, such as nose, eyes, etc are not subsurfaced, but do not appear.

Additionally, although the head has very small angles, auto smooth seemed to have no effect.

How are things in Palmer? I spent to very enjoyable years in Alaska about 40 years ago, courtesy of the United States Air Force.


(Santiago) #4

Nope. Putting camera, objects which disappear, and the lights on the same layer doesn’t change anything. :frowning:


(yann) #5

Are all the normals pointing outwards? Ctrl+N, or show normals and flip normals, may help you. Or setting the faces to be double-sided.


(theeth) #6

you’re probably over the vertex limit for that particular object. Lowering subsurf makes it works since it reduce the face and vertex count.

sad but true

Martin


(Santiago) #7

You guys have some good ideas to try! It’s got me thinking, which my wife would tell you is dangerous! :wink:

Reading your suggestions, a test came to mind which might help further define the real nature of the problem. I took a copy of the object, and placed nothing but it, a camera, and a couple of lights in a scene. Voila! It renders!

This “object” is in fact built of a number of sub-objects (head, hat, nose, eyes, etc). I tried adding smoothing and subsurfaces to each, until I had maybe twenty of the sub-objects smoothed and subsurfaced. It still renders!

THis makes me think that it is interaction in some way with the scene in which it is used . . . as though the software did not have enough resources of some sort.

I haven’t looked at making the object double surfaced, or at the direction of the vertices. Given the above, I don’t think that’s the problem, but I’ll try it next … just to be sure.


(theeth) #8

then, if it renders indivudually, it must be the total vertex limit… strange though, it usually gives a warning in the console when you reach that limit no?

Martin


(MoreK) #9

Which version do you have? If you are using 2.25 try 2.23 instead. I had same kind of problems and they vanished with 2.23.


(Santiago) #10

A quick check shows I’m using 2.23. That’s a good tip, though!

No, I haven’t seen any errors on the console. I’ll go back to the full scene, and try removing objects to see if things suddenly satart working. It acts like that sort of problem: one hits the limit of what a piece of software can do, then things turn up missing.

Please stay tuned … your help and ideas are definitely appreciated!


(CurtisS) #11

While the viewport is in Camera view, try toggling the little View Lock (padlock) button next to the layer buttons (with all layers selected ON). It could be that the camera view is locked only to the layer that renders.

Aloha for now!

CurtisS


(Santiago) #12

Nope. A good idea … but it didn’t work. I have established that unclicking auto TexSpace, smoothing, and everything else in that column will allow an occasional missing object to be seen. (I’m referring to the “Edit Buttons” window)

Clicking “Set Smooth” in the next col to the right will sometimes allow the object to be rendered in a smooth state.

Increasingly, I suspect the comments about the number of vertices are on target, although I’m certainly game to try other approaches.

The objects which have this problem were 3ds objects, which were converted to 3dx, and imported into Blender. I used AccuTrans 3d to make the conversion. It looks as though Accutrans may have the capability to reduce the number of vertices, so I’m going to try that, and see if it makes a difference.

It’s rather wierd. I can see the objects in the perspective mode, yet when I render them, they disappear! It’s tempting to make the perspective window the size I want the final image, screen capture, then paste the result in a file. It would be tough to do the animation I’m trying for that way, though! Lessee … three minutes times 60 seconds per minute, times 30 frames per second is 5400 images . . . :smiley:


(theeth) #13

did you try doing a remove doubles? Sometimes, when importing files, the vertex are doubled…

you could also use the decimator, of course…

Martin


(Santiago) #14

I’m a total newbie to Blender, having just recently made the change from Imagine. Thus, some of the commands still elude me. I was fortunate enough to find a copy of the Blender guide at Barnes and Noble, and it lists “remove doubles,” so I’ll give that a whirl.

The “decimator,” however, eludes me. Is this a command?

The guide is good material, but it isn’t fully indexed, so something like “decimator” may be present, but difficult to identify.

At the moment, I’m re-importing all the objects, after doing a merge vertices in Accutrans 3d. When I’ve cleaned them up as much as possible, I’m going to rebuild the scene, and see if the problem recurs. Thus, your ideas fit in well with the direction I’m headed. Many thanks!


(S68) #15

It is a slider.

In the mesh editing window (F9) In the center there is the DECIMATOR slider.

Select an object OUT of edit mode (it is pink, nodes are not shown)

The max value of the slider is the FACE COUNT of that object.

You can slide it down and blender ‘decimates’ the faces to the number of faces you desire.

This is done by merging neighbouring faces with approximately the same normal.

Pay attention, if you decimate too much you loose shape :slight_smile:

After sliding the mesh is shown and you can decide to accept or reject the decimation with the two buttons underneath.

Stefano


(Santiago) #16

We are too soon old, and too late smart! The person who said this probably wasn’t doing rendering, but he/she might well have been doing so. I tried the two techniques mentioned above. It was a worthwhile exercise, and seemed to help some of the objects, whose vertices were alternately appearing and disappearing during the animation.

I was never able to get the scene as I had it constructed totally functional. I rebuilt it by loading the primatives I’d previously built, and most things started working. Evidently, something in the first scene I built was corrupt.

It was a good learning experience, but it did not solve everything. I have eyeballs (white) and pupils (black) modeled as spheres. The eyeballs show up fine, but the pupils disappear when they are less than approximately half the size of the eyeballs. This happens in closeups, distance shots, etc.

I’ve tried different textures, different numbers of vertices, etc etc. I have no explanations; I pass this along so that the next person who experiences this will know they aren’t totally nuts. :wink:

It’s a great program, and I’m learning as I go along! Thanks for everyone’s suggestions, whether they worked or not. They all helped, by making me think why they should … or should not … have anything to do with the problem! Sometimes, asking myself why I don’t think someone’s suggestion will work is as much value as having the final answer.


(z3r0 d) #17

is it possible that objects are close together from the point of view of your camera?

for example:
Imagine a sheet of paper in front of the screen of your monitor. Blender (and opengl in general) can not always tell if the paper is in front, or the screen. Often this results in a kind of flicker where changing parts of each face (the screen, and the paper) are visible.

Or possibly you have a zoffset set to an extreme?

… or maybe it was a corrupt file. as you suggest.