Missing Wireframe Edges

(LHammonds) #1

Blender Version: 2.45
Python Version: 2.5.1
ATI Radeon X850 Video Card with Catalyst 7.2 drivers

Please see attached image (or here if attachment doesn’t work)

Question: How can I get wireframe mode to show all the edges?

EDIT:
Answer: Blender does it’s own edge calculation so you can’t really. If you need it to help create a screenshot effect, you could export your model to a Microsof DirectX .x format and then import the file which will separate all shared verts will allow you to go into wireframe mode and it will show each and every line.

I’ve spent a long time placing verts in just the right places and was surprised when I went into wireframe mode that many edges were invisible. There seems to be no problem in Edit or Render mode.

I’ve tried saving, closing and re-opening. I’ve tried deleting and re-adding faces and edges. In edit mode, I’ve tried to click on edges that were visible and edges that were not visible in wireframe mode to see if there were any differences in settings but found nothing. I’ve tried searching for “Missing Wireframe Edges” and similar variances and found no topics or tutorials about this.

Either this is something very basic that a noob such as myself has overlooked or it might be a bug in the new version of Blender. :confused:

Thanks,
LHammonds

Attachments


0 Likes

(ikee) #2

while in edit mode go to the editing panel(F9). At the tab Mesh Tools 1 press the All edges button.
And there you go…

0 Likes

(LHammonds) #3

I also found out that set smooth will look all wacked out if the wireframes do not match the actual edges. Please see the attached screenshot for an example. (click here for and alternate link)

FYI - I did find the button called “All Edges” on the “Editing (F9)” panel under the “Mesh Tools 1” section but it only shows the entire wireframe when looking on the screen and doesn’t actually fix the issue because it still hoses up the “Set Smooth” option when rendering. :confused:

Any help is appreciated,
LHammonds

EDIT:
Question: How a render such as this be messed up when Rendering with “Set Smooth” enabled on the mesh?

Answer: This problem was actually an incorrect setting on the “Map Input” tab of the Material Buttons panel. It was mapping to “Orco” instead of “UV”

Attachments


0 Likes

(ikee) #4

try calculating the normals outside Ctrl + n might help. Maybe the Autosmooth could work with the issue too

0 Likes

(LHammonds) #5

ikee, thanks but both of those still don’t fix the wireframe. It might have fixed the render problem though…hard to tell since I’m in the middle of doing the UV Map.

Any other suggestions out there to correct the wireframe?

Thanks,
LHammonds

0 Likes

(jestmart) #6

This is most likely due to the latest Blender version not playing well with your graphics card. Similar problems have popped up over at the Renderosity Blender forums.

0 Likes

(LHammonds) #7

Thanks for the tip. I’ll revert back to 2.44 and see if it helps. Hopefully it’s not too late for this model. :wink:

EDIT: Just tried Blender.org’s old archive and their server seems to be dead. Good thing I’ve packaged older software bundles at TESNexus.com hehehe.

LHammonds

0 Likes

(LHammonds) #8

[strike]Ah ha! I figured out a work-around to fix the wireframe. I’m not 100% certain how the wireframe got wacked out…maybe the way I was modifying things or maybe it’s a bug in Blender 2.45 but I exported it to .OBJ format and then re-imported it and the wireframe now look correct.[/strike]

EDIT #1: Oops. It turns out that didn’t fix it afterall. It looked like it was fixed but it’s not. :frowning:

EDIT #2: I wondered why I would post a finding when it was in error and thought myself stupid for not paying attention and decided to repeat my steps to see where I was confused. I found out that the wireframe “looks” perfect until you go into Edit Mode and then back out again (without actually editing anything) and the wireframe is updated to show the original problem. Either this means the wireframe view wasn’t showing the problem or that going into Edit Mode re-introduces the problem. I kinda think the problem stayed with the mesh.

Screenshot of the wireframe view immediately after import
Before and After screenshots in wireframe mode #1
Before and After screenshots in wireframe mode #2

LHammonds

0 Likes

(LHammonds) #9

I’ve looked at other meshes I’ve worked on and wireframe issues exist on those as well.

Any other ideas on how to correct the wireframe?

0 Likes

(LHammonds) #10

Darn…was hoping somebody had an easy answer for this.

I decided to try other export formats to see if I could resolve the problem but I knew there would be other issues that would crop up if I did this.

OBJ - Exporting and re-importing from this format didn’t fix it.
DXF - Exporting/re-importing didn’t work.
3DS - Exporting/re-importing didn’t work.
LWO - Exporting/re-importing didn’t work.
X - Exporting/re-importing DID work. Microsoft Direct-X format seemed to fix the wireframe issue but the export/import created other issues. The UVMap is a bit off but I think it’s not too bad and can be corrected (but I loose my “pinned” verts). Also, each vertice is separated and usually cause triple to quadruple the number of verts. For example, a single vert that was connected to 4 faces is now 4 verts in a single space. I either have to select each vert with a block command and tell it to merge/center or figure out a way to merge all verts that are overlapping. :frowning: I don’t know what other issues there are at the moment but thought I’d share what I’ve found so far.

If you guys haven’t seen problems with your wireframe, you might want to take a look as it DOES affect things such as renders and such.

LHammonds

0 Likes

(Cire) #11

I’ve seen this before in my own meshes. I just assumed it was a minor display issue. I never knew what caused it . . . and I know I’ve seen it before version 2.45, too.

0 Likes

(LHammonds) #12

It was version 2.45 that I noticed the problem in.

I did find that after you re-import with Direct X format, you can select all verts and click Mesh, Vertices, Remove Doubles and it will fix the issue of having to merge each set of duplicated verts manually BUT this re-introduces the wireframe issue. AARRRRGGG!!!

I’ve been able to replicate the issue on Blender 2.44 and 2.45.

It occurs when you merge two or more vertices. When you select two verts and click “F” to create a line between them, the wireframe never sees this line. I will have to check and see if this also occurs on older versions as well. Not knowing how to get Blender’s wireframe mode to re-recognize the new lines is very irritating.

0 Likes

(LHammonds) #13

I’ve done a little more research on this subject and have found the following to be true in Blender 2.43, 2.44 and 2.45 (have not tested any other versions)

When doing a subdivide multi on a line, the added vertices and lines to not alter the wireframe and will not show up unless the faces are deleted. Screenshot Proof

Extruding the sub-divided line (when including edges) will only show the outside edge in wireframe mode. Screenshot Proof

Extruding the sub-divided line (when including just verts) will show each line in wireframe mode. Screenshot Proof.

Attaching faces to the above lines moves the wireframes from the inside lines to just the outside edges. Screenshot Proof.

The logic of automatic determination of which lines will be included in the wireframe and which will not seems to be designed into Blender but it’s confusing as you-know-what when the wireframe does not actually represent your model such as in my first posting and when the wireframe seems to “play” with how Blender renders the mesh and lighting.

Confused…:spin:
LHammonds

0 Likes

(jestmart) #14

Edges not showing in Object mode when in wireframe is an old problem. Edges disappearing in Edit mode is something new. I’ve been lucky that while my computer’s integrated GPU chip is ancient it adheres to the OpenGL standard very closely (version 1.2 is all it capable of though) and I haven’t had many of the visual problems other have.

0 Likes

(Cire) #15

@ jestmart: I don’t think LHammonds mentioned having edges disappear in Edit mode, did he? That would be really bad.

0 Likes

(LHammonds) #16

Edges are not disappearing in Edit Mode.

The issue is with Wireframe Mode not showing all the lines or not giving you the option of which lines to show in Wireframe Mode. The wireframes apparently affect the smoothness of the final Render as well as discoloration as demonstrated in the first post.

I’m just about to give up on this as I have not found a good work-around or solution. I just hope it doesn’t affect the appearance of the model once I get it into my Oblivion game.

LHammonds

0 Likes

(jestmart) #17

Perhaps disappearing was the wrong term. In one picture I did see major gaps in the edges but maybe that was just jpeg artifacts. The edges not showing in Object mode is annoying (especially if you’re trying to align separate meshes) but it has no effect on the model.

0 Likes

(LHammonds) #18

No effect on the model? Well, that might be true for the actual verts, lines and faces but did you see what the Render looked like when I enabled “Set Smooth” (Post #3). The mesh has a very smooth curve for the front but it appears that the wireframe somehow affects the Render when “Set Smooth” is enabled which makes it look awful…even less smooth than when “Set Solid” is enabled.

I still have not been able to get it in-game yet to see what the results are due to some kind of “global” error on export to NIF. Gotta go figure that out now.

LHammonds

0 Likes

(Cire) #19

I’ve never seen this display error cause any problems with smoothing/rendering. Are you able to post a .blend for others to check out?

0 Likes

(LHammonds) #20

Even though the rendering looks messed up, the model works perfectly in-game.

If the attachment doesn’t work, here is a direct link to screenshots in-game which shows that the model is nice and smooth. :smiley:

I’d prefer not posting the .blend file on a public forum but if anyone wants to take a look, send me an email and I will reply back with an attachment.

For now, I’m using TESSourceFiles [at] GMail [dot] com

LHammonds

Attachments





0 Likes