missles dont move

I just started making games 3days so I dont know much yet and I have a problem. I have a jet moving at high speeds thout the air and I want it to shoot missles, I set up an edit object actuator so it adds a missel when I press m but the missles just sit there in mid air even though ive set their starting velocity to 100!:spin: whats going on here? am I doing some thing stupide?

Put your missile in inactive layer, make it a dynamic actor . Post a .blend file if you have more problems.

I thought they were on a inactive layer and I know they were dymanic(because I even tryed seting them to always move forward). and I know they are not just moving to slow to notice be cause I run the game from a fix camera angle to check that. so here a .blend hope it works.


also how do I make the movement more realistic.

There’s some kind of problem with the missile object. Make a new dynamic object and change its mesh to the missile mesh. Remember to change the object name in the add object actuator. I tested it and it works.

Ok them move now but fireing them causes my jet to spin and the also ver off to one side. also how could I make them shoot toward the middle of the screen.

It happens because they collide with the ship.

but they are set to ghost, dosnt that mean they dont collide with any thing? and why are they turning to on side?

As discussed here about thousand times recently, ghost setting doesn’t work on added objects because of a bug. Turning is caused by the same collision. Just adjust the position and rotation of the launcher empty so that missiles don’t touch the ship when they’re created.

Try turning off collision settings