Mist not covering 3d objects in the background

Hi all

I have this rain forest scene. It is being rendered in Blender Internal. I added in mist but after rendering I noticed that the mist was not covering up one of my plants in the background.
Here is a screenshot showing the problem.



As you can see everything is fading out the and then one plant doesn’t fade.

Please help

Thanks in advance
Ivan Kahl

that is really odd. it must be a bug. the only thing I can suggest is to replace it with a different plant, or a shadeless billboard / alpha texture, made from the original plant, and perhaps make a bug report. is this version 2.65, or 2.65a?
(edit) another thing you could do is try substituting a volumetric cube for the mist setting. It would take a lot longer to render but would achieve the same effect.