Mix RGB Screen and Add modes darken image


I’m trying to do some basic compositing inside blender. I would like to add some more volumetric light pass on top of beauty. In order to control it better i used the RGB Curves node to cut the darkest parts, and leave only brightest areas. But after plugging it into RGB Mix node, (Screen or Add), it darkens the whole image instead of brightening only chosen areas. How could I solve that?

Thanks for help!

Welcome @Mkbart.

Maybe you wanna have a look at @BlenderBob 's latest video tutorial (<6min): Mixing volumetric light. ? He is using a depth layer to make a better mix with volumetic light (using eevvee or cycles doesn’t matter, it’s just faster to composite them)


Hi Okidoki!

Many thanks for your reply, the tutorial was very informative and I will definitely consider using it for my scene for this purpose.

My question, however, is also more of a general type. I plan to do some more advanced compositing in the future, and this behaviour of “Screen” mode is totaly not intuitive for me, compared to other software like PS, Fusion or AE.
The only node that allowed me to control input passes correctly was Color Ramp, but this method outputs only black and white. Either RGB Curves, Brightness/Contrast or Color Correction nodes result in Screen mode darkening the black parts. Do you have any idea could I solve that?

Having a closer look at you image i notice your RGB curve is not even modified and you only have a Viewer node and no Composite node in you compositor. And about the blending node: choosing something other than mix is a matter of taste i guess and it could be that the modes slighty differ in blender than in other SW. IDK. :frowning:

The RGB node is cutting the darkest parts of my volumetric pass. It has only slight X shift towards right. You can see the difference it makes in my screenshots, it produces Color Corrected Volumetric Pass.

I was using the Viewer node only, as I needed only to preview the final effect. Adding composite node hasn’t changed anything yet, unfortunately…

Could it be that somehow negative values are fed into the second input of the screen node? This would lead to a darkening effect. Maybe you could place another mix rgb node with factor 0 but clamping enabled in between the curve node and the screen node?


So i should have done a closer closer look :wink:

That seems to be the case! Adding 0.0 Fac Mix node with Clamp seems to help. How simple shift in curves or contrast ends up producing negative values - it’s beyond my understanding of CG math. Is it something that could be considered a bug in Blender? I can’t see any pros of this behaviour…

Thanks anyway! That is what I needed.

1 Like

No worries, your initial response was helpful as well!