Mixamo animations blending problem


Hello! I have some problem with combining two mixamo animations. When i set blending between these two animations my character gets a little unexpected spin in few frames. How can it be fixed?

Blend file: https://drive.google.com/file/d/1dEJ-zH4cc1u6c7FckEu6JGJ2iZuDv3Hn/view?usp=sharing

Here is what I did…
Go NLA track and delete the Move 2 track…
Open in a new window the Action editor and in the drop-down select the Move 2 action…
It should pop up in the NLA tracks…Push Down…Readjust the blend…
I set it at 18 frames before the end of Move 1…and it should be above the Move 1 track after pushing down…
There is a little skip on raising the sword but can’t be helped with out doing a couple tweens between them…

Hi! Thank you for replying! I did all what you said but it didn’t help me… I still have this strange rotation of my model. Maybe i am too stuiped. (actualy i know english quite bad so i could missunderstood you). For example: “Readjust the blend” Does it mean that you just moved strip but didn’t use “Blend in” option. I have this issue only when i use “Blend in”. So do you propose: “Not use Blend in”? Can you share your blend file?

Correct…I didn’t use the blend in, I just positioned the Move 2 track in position to fit over Move 1…

Here is the Blend-File…(Had to redo it as It was not saved… :wink: )

Thank you again! I try to understand… Does “blend in” always work bad? Or only in my case.

Sorry just saw this…
FYI…you need to click on the Reply icon in my post for me to get a notification…

I think it was just your case as the second animation was just too many frames ahead of the last keyframe of the first… sometimes on miximo you might need to expand the TRIM Frames a bit in the beginning and the end…then when mixing you have a few extra frames to play with…

Thank you! I’ve already solved the problem!

Good to hear! Happy Blending!